Results 1 to 4 of 4

Lost my highs

This is a discussion on Lost my highs within the Stereo and Electronics forums, part of the General Help category; I no longer have any highs even with the equalizer up as far as it will go. Sounds like it's ...

  1. #1
    Junior Member AtLarge's Avatar
    Join Date
    Aug 2005
    Location
    In a house
    Posts
    65

    Bright Metallic Blue A4
    1999 WS9

    Angry Lost my highs

    I no longer have any highs even with the equalizer up as far as it will go. Sounds like it's all midrange and bass. Is there a shop that can work on the Monsoon to try and save it or should I just start shopping for an aftermarket?
    I was here before the server crashed.

  2. #2
    Member
    Join Date
    Oct 2006
    Location
    Springfield
    Age
    30
    Posts
    330

    Silver
    2004 SVT Cobra

    You could probally find a shop in your general area to do it, but with parts and labor you can expect to pay around the hundred dollar range. My advice would be to get a good aftermarket unit, that alone will dramatically increase the sound quality of the monsoon system. The stock head units are junk.

  3. #3
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    The tweeters might have blown.

  4. #4
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Don't waste your time or money on the stock headunit or system.

    Get an aftermarket headunit with 3 preamp outputs, and then get new speakers for the rear sailpanels and front doors (which are components) and just disconnect the trunk speakers. If you try and use the trunk speakers, you'll probably just end up with an echo effect, which you don't want.

    Then you can do any combination of upgrades. You can keep the stock wiring and amp, and just upgrade the headunit and speakers. Or you can get a new amp as well, and run RCA's and new speaker wires. Then if you want to add a sub, all you need to do is run RCA's from the 3rd preamp output (sub out) to a sub amp and and sub/box. I highly reccommend JBL speakers as well, I have them in both my cars and I've been very impressed with them overall.
    1998 Trans Am WS6 SGM
    Lid, Pro 5.0, WS6 Short Stick, LS7 Clutch, TB Bypass, Detroit TrueTrac, Poly Mounts, Bilstein Shocks, LS6 Intake, SFCs, CTS-V Brake Upgrade, STB, Nitto 555's. SS Longtube Headers and True Duals w/ H pipe and Magnaflows. Tuned by Harris Speed Works. 341.4WHP/346.1 lb/ft.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LOST
    By Blown Interceptor in forum Almost Anything Goes
    Replies: 13
    Last Post: 01-22-2009, 04:12 PM
  2. Wiring Highs into the Sails
    By Selride in forum Stereo and Electronics
    Replies: 7
    Last Post: 12-03-2007, 03:25 PM
  3. installing aftermarket highs in 02 camaro
    By williams2k4 in forum Stereo and Electronics
    Replies: 8
    Last Post: 04-19-2007, 04:25 PM
  4. Lost a t-top at about 90!
    By 99z28mike in forum Camaro / SS
    Replies: 2
    Last Post: 01-27-2007, 11:25 PM
  5. lt guy got lost
    By faust in forum New Member Introductions
    Replies: 4
    Last Post: 01-27-2007, 06:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •