Results 1 to 4 of 4

installed my new Alpine HU today, need help.

This is a discussion on installed my new Alpine HU today, need help. within the Stereo and Electronics forums, part of the General Help category; well, me and my friend got it hooked up so that I can use my ipod and cd's, but the ...

  1. #1
    Aw shucks. bluefields88's Avatar
    Join Date
    Jul 2006
    Berkeley, CA

    2000 Camaro SS #3574 A4

    installed my new Alpine HU today, need help.

    well, me and my friend got it hooked up so that I can use my ipod and cd's, but the antenna cable wouldn't fit into the socket for it on the HU. is there a connector I need to get for it or something? and I bought a steering wheel control module for it, but the company didn't have any instructions for Camaros. It said it was supposed to work with my car, but we have no idea how to get it to work. it's a PAC SWI-Jack module. Anyone ever install one?

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    doylestown, Pa

    2004 CTS-V

    You need to get an adapter for the antenna. Go to a good stereo shop and they will know what you need.

  3. #3
    Crazy Canuck ! Eugenio_SS's Avatar
    Join Date
    Jun 2002
    Montreal, CANADA

    2000 CamaroSS convertible

    here is an example of what you need:
    almost stock triple-black 2000 SS convertible with 17x11s on all 4 w/ 315s at the track or on the street with 18x10.5s on all 4 w/ 315s: (1), (2)

  4. #4
    Junior Member munecorey`'s Avatar
    Join Date
    Feb 2008

    98 trans am

    yes you do need an adapter, you can get one at walmart. is called a gm antenna adapter, i don't know if they sell them alone or with the wiring harness, but is like 7 dollars. For the swi jack, is easy to install, what you need to do is connect the jack to the stereo your stereo should have an input that is called the oem factory steering wheel radio or something like that, well you connect the jack to the input in the h.u. NOw you only need 3 wires from the swi jack, green red and black. you connect the green wire from the swi jack, to a dark blue cable from the cars wiring harness it should be on pin #14 be careful theres 2 dark blue ones! next you connect the black wire to a ground and the red one to the red wire from the factory wiring harness. Now comes the hard part programming it. Go to their site for specific programming instructions depending your h.u. heres the link!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 07-15-2007, 12:02 AM
  2. alpine dvd player for sale
    By jimmyboy8301 in forum Parts For Sale / Trade
    Replies: 6
    Last Post: 07-02-2007, 07:01 AM
  3. Installed my Q-tec today
    By anti-social in forum External Engine
    Replies: 0
    Last Post: 09-16-2006, 03:03 PM
  4. SLP lid installed
    By jag42420 in forum External Engine
    Replies: 4
    Last Post: 09-12-2006, 09:32 PM
  5. F/s: Locally: Custom Stereo, Alpine, Jl Plus Wheels & Tires
    By MAP1964 in forum Rocky Mountain Members
    Replies: 5
    Last Post: 03-31-2006, 07:53 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts