Results 1 to 8 of 8

Having problems with my fog lamps

This is a discussion on Having problems with my fog lamps within the Stereo and Electronics forums, part of the General Help category; ...

  1. #1
    Just a slow Camaro KING Z28 HAWK's Avatar
    Join Date
    Oct 2007
    Location
    Fresno Ca
    Posts
    2,228

    LPM
    2002 Z28 Camaro

    Having problems with my fog lamps

    I got my subs and amp put in back in December and I went to turn them on tonight and they arenít working any suggestions what might be wrong?

  2. #2
    Member 02WS6dream's Avatar
    Join Date
    Jun 2006
    Location
    Charlotte, NC
    Age
    34
    Posts
    668

    08 Mustang GT/CS Blue
    2002 Trans Am WS6 traded

    tried to turn on fogs after amp/speaker install??? Only thing i can suggest is that maybe they pulled the panel under the stearing wheel to run signal/power cables and pulled wires loose from the foglight switch. I would check that the leads behind the switch are still attached. Otherwise, it may be unrelated. no alarm installed? that would seem more likely to cause problems, since it ties into the switch..

  3. #3
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Does the light on the switch light up if you hold it down?

  4. #4
    Junior Member
    Join Date
    Feb 2008
    Location
    Dyer IN
    Age
    30
    Posts
    7

    Pueter/Silver
    1999

    Having problems with my head lights when i turn them off they are makin a buzzzing sound. and when i turn on my runnin lights my head lights pop up..any suggestions what might be wrong? is it the moter or is there a relay that went bad...

  5. #5
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    Quote Originally Posted by KING Z28 HAWK View Post
    I got my subs and amp put in back in December and I went to turn them on tonight and they arenít working any suggestions what might be wrong?
    check your fuses, they could have shorted something out while working on it,...next step i would check your connection wires,...also check your bulbs...does the button for the light light up??

  6. #6
    Just a slow Camaro KING Z28 HAWK's Avatar
    Join Date
    Oct 2007
    Location
    Fresno Ca
    Posts
    2,228

    LPM
    2002 Z28 Camaro

    Quote Originally Posted by 02WS6dream View Post
    tried to turn on fogs after amp/speaker install??? Only thing i can suggest is that maybe they pulled the panel under the stearing wheel to run signal/power cables and pulled wires loose from the foglight switch. I would check that the leads behind the switch are still attached. Otherwise, it may be unrelated. no alarm installed? that would seem more likely to cause problems, since it ties into the switch..
    i didnt turn them on after they were installed shit i should have tho. i'll check all that out in the morning thanks

  7. #7
    Just a slow Camaro KING Z28 HAWK's Avatar
    Join Date
    Oct 2007
    Location
    Fresno Ca
    Posts
    2,228

    LPM
    2002 Z28 Camaro

    Quote Originally Posted by bigrondownhiller View Post
    Does the light on the switch light up if you hold it down?
    no it doesnt

  8. #8
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    then there is no power. First check the fuse. Are your high beams on? If they are on the fogs go out I think.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fog lamps
    By 99pewterta in forum General Help
    Replies: 6
    Last Post: 08-11-2009, 06:48 PM
  2. Fog Lamps
    By SOCAL WS6 in forum Firebird / WS6
    Replies: 4
    Last Post: 01-03-2009, 11:21 AM
  3. fog lamps
    By txz28 in forum Camaro / SS
    Replies: 1
    Last Post: 08-17-2008, 01:26 AM
  4. Trans Am Fog lamps
    By Fade2Black in forum General Help
    Replies: 1
    Last Post: 02-27-2007, 01:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •