Results 1 to 5 of 5

fittment problems?

This is a discussion on fittment problems? within the Stereo and Electronics forums, part of the General Help category; Does anybody else have the problem of having the 6 1/2" speakers not fit properly on the rear seat side ...

  1. #1
    I Drive A 95' AfterYou's Avatar
    Join Date
    Aug 2009
    Location
    Granbury, Texas
    Posts
    441

    01' Firebird Pewter
    98' Trans Am Black

    fittment problems?

    Does anybody else have the problem of having the 6 1/2" speakers not fit properly on the rear seat side panel speakers? I just got a pair of Sony's and the screw holes arent wide enough, Same with some mtx speakers I had

  2. #2
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Never had an issue with mine
    Got any pictures of this
    Last edited by tatertot91; 06-09-2011 at 12:39 PM.

  3. #3
    Member ls1ws6ben's Avatar
    Join Date
    Apr 2010
    Location
    west monroe, la
    Posts
    246

    white
    1998 Trans Am

    my memphis 6 1/2s wouldnt line up with the stock holes.. had to make a mounting bracket to fit mine.. but it worked out fine

  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    The rear speakers are actually 6 3/4. Most speakers come with adaptors to make a 6 1/2 fit. Some are compatible with both sizes. If they fit the hole you could just drill new holes for the screws.

  5. #5
    Junior Member
    Join Date
    May 2011
    Location
    Farmingdale, NY
    Posts
    80

    Black
    1998 Pontiac Trans Am WS6

    Just had a problem putting Infinity 62.9i's in the rear. I couldn't use the existing screws and mounting hardware. I was able to use the hardware which came with the infiinity's though...I'm finding every speaker in this car is a PITA to replace...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Hid problems!!
    By 01ls1ws6 in forum Firebird / WS6
    Replies: 15
    Last Post: 06-24-2010, 08:17 PM
  2. 2 problems
    By Darkrider02 in forum General Help
    Replies: 5
    Last Post: 06-10-2010, 05:53 PM
  3. t56 problems
    By djbcrazy7 in forum Manual Transmission
    Replies: 2
    Last Post: 04-11-2007, 07:59 PM
  4. TH400 & LS2 fittment
    By 85lux in forum Automatic Transmission
    Replies: 5
    Last Post: 06-24-2006, 07:06 PM
  5. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •