Results 1 to 3 of 3

blinker issue

This is a discussion on blinker issue within the Stereo and Electronics forums, part of the General Help category; so i was driving along and tryed to use my right blinker and i noticed it would come on but ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    texas
    Age
    39
    Posts
    25

    artic white
    2000 SS LS1

    blinker issue

    so i was driving along and tryed to use my right blinker and i noticed it would come on but wouldn't blink. So i went to auto zone and turned all my lights on and checked all my lights, sure enough, the front right blinker was out. So i got a replacment bult and replaced it(the old bulb was blackish). Then i tested the right blinker and it still will not blink... The new bulb does light up but just doesn't blink. All my other lights are working, what am i missing here? I thought all i needed was to replace the bulb that was burned out and everything would be fine but now i duno what to do. Any help is appreciated. thx

  2. #2
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    40
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    Check to see if there is a ground wire loose. That would make it do that. I can't remember if there is a ground wire on them or not.

  3. #3
    greasy-chicken
    Guest

    Arrow Re: blinker issue

    Also check to make sure you got the right replacement bulb. The front light is a blinker and a running light so it needs two filiments. Check the bulb socket as well. Besides my TA I have a GMC Yukon. The blinker bulb in the rear tail light was not working even with a new bulb. I discovered it was the socket that was bad. I had to order a new socket plate and that solved the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issue.. may be tune issue.. help?
    By okiels1 in forum General Help
    Replies: 2
    Last Post: 12-07-2016, 03:17 PM
  2. pvc issue... vacuum leak....tune issue?
    By okiels1 in forum General Help
    Replies: 3
    Last Post: 03-05-2016, 10:10 AM
  3. Help: tranny issue think it might be planetary issue
    By nerisls1 in forum Automatic Transmission
    Replies: 6
    Last Post: 03-05-2009, 10:32 PM
  4. Blinker Issue
    By DB69TA in forum Stereo and Electronics
    Replies: 4
    Last Post: 11-10-2007, 06:27 PM
  5. Blinker Issue
    By bwinch in forum General Help
    Replies: 0
    Last Post: 07-30-2007, 06:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •