Results 1 to 5 of 5

Blinker Issue

This is a discussion on Blinker Issue within the Stereo and Electronics forums, part of the General Help category; I am currently having a problem with a left blinker. I have successfully changed both left and right bulbs, both ...

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Location
    Houston
    Posts
    2

    White
    1999 Trans Am

    Blinker Issue

    I am currently having a problem with a left blinker. I have successfully changed both left and right bulbs, both light housings and both light sockets. Both lights come on bright when driving but the left one just won't blink. I checked for fuse issues and all seems fine. I was thinking about changing the blinking switch but is that in the steering column or under the dash? Appreciate any feedback.......thanks in advance.

  2. #2
    Junior Member redwolf28's Avatar
    Join Date
    Sep 2005
    Location
    So Cal
    Posts
    33

    Arctic White
    2001 SS

    You say that you changed left and right blubs. Is that front or rear turn signal blubs? If one of your turn signal blubs are burnt out, it won't blink.

  3. #3
    Wants to be Snowboarding FuhBreezeE's Avatar
    Join Date
    May 2007
    Location
    DFW
    Posts
    7,603

    Stg IV a4
    '99 TA Ws777

    My left rear blinker doesn't flash, just stays on when I signal and both of my driver's side high and low beams are out...

  4. #4
    Asshole bige97's Avatar
    Join Date
    Jul 2007
    Location
    Virginia
    Posts
    576

    Red
    '01 Silverado

    did you change the blinker fluid?(srry being a smart ass)

  5. #5
    Junior Member redwolf28's Avatar
    Join Date
    Sep 2005
    Location
    So Cal
    Posts
    33

    Arctic White
    2001 SS

    Check fuse labeled LH HDLP DR in fuse box in your engine bay. It is might be bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issue.. may be tune issue.. help?
    By okiels1 in forum General Help
    Replies: 2
    Last Post: 12-07-2016, 03:17 PM
  2. pvc issue... vacuum leak....tune issue?
    By okiels1 in forum General Help
    Replies: 3
    Last Post: 03-05-2016, 10:10 AM
  3. Help: tranny issue think it might be planetary issue
    By nerisls1 in forum Automatic Transmission
    Replies: 6
    Last Post: 03-05-2009, 10:32 PM
  4. Blinker Issue
    By bwinch in forum General Help
    Replies: 0
    Last Post: 07-30-2007, 06:15 AM
  5. blinker issue
    By 2kSSnTX in forum Stereo and Electronics
    Replies: 2
    Last Post: 08-15-2005, 08:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •