Results 1 to 12 of 12

Anyone else have problems with ledgauges.com cluster bulbs???? (w/Vid..)

This is a discussion on Anyone else have problems with ledgauges.com cluster bulbs???? (w/Vid..) within the Stereo and Electronics forums, part of the General Help category; Several months ago i got a set of Blue LED cluster bulbs from ledgauges.com They all looked GREAT..... for about ...

  1. #1
    Junior Member
    Join Date
    Sep 2006
    Location
    Smithtown NY
    Age
    30
    Posts
    94

    White
    1999 T/A

    Anyone else have problems with ledgauges.com cluster bulbs???? (w/Vid..)

    Several months ago i got a set of Blue LED cluster bulbs from ledgauges.com They all looked GREAT..... for about a month. soon after two of the bulbs died. this week a THIRD one that was dimming also Died AND the fourth one has been Flickering like a bitch lately. ive tried just about everything possible. i bend the brass clips in to get a tighter connection, i hot glued the bulbs in so they dont wiggle, and jsut about everything else. so im just curious...... Is there anyone out there who has been having similiar problems to me? ive been talkin to ledgauges guy to get some new bulbs but its a slow process, and as much as i hate to do it, im on the verge of going to the site and just ordering another set for 35 bux just so i can see my friggin cluster at night and because when they worked they looked VERY good. any ideas?

    also i put a video on youtube of the flickering bulb. you can also see in the middle of the cluster its very dim, and on the left and right the bulbs are normal color because after the other 2 died, i just put the stock ones in so i could see my gauges at night. so basically now ive got one working blue bulb.


    http://www.youtube.com/v/zbmrfWbKG5g
    (i just uploaded it so the vid will be ready in a couple)

  2. #2
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    that sux

  3. #3
    Junior Member
    Join Date
    Aug 2006
    Location
    no where
    Age
    30
    Posts
    89
    its cause ur car sucks plain and simple

  4. #4
    Junior Member
    Join Date
    Sep 2006
    Location
    Smithtown NY
    Age
    30
    Posts
    94

    White
    1999 T/A

    vid now works up!!!!!!!!!!!

  5. #5
    Member SSmoky01's Avatar
    Join Date
    Sep 2006
    Location
    Central,Texas
    Age
    38
    Posts
    447

    Navy Blue Metallic
    2000 Camaro Z-28 SS

    Bummer dude. Glad I didn't buy any.

  6. #6
    SS-EIAN SSNAKEATER23's Avatar
    Join Date
    Oct 2005
    Location
    CHICAGO
    Age
    37
    Posts
    616

    SILVER
    1999 CAMARO SS

    thats horrible......always buy more than one set
    Whisper Lid/SLP HarmonicBalancer/MAFTranslator/DiabloTuner A-Pillar Gauges (Aem Uego A/F,Trans Temp, D-Pic)Magnaflow CB w/CME Tips/ Eibach Pro Kit/ Brembo Cross Drilled/Slotted Rotors/ H.I.D.Kit

  7. #7
    Member
    Join Date
    Oct 2005
    Location
    Austin, Tx
    Age
    33
    Posts
    532

    Black/Black
    2000 Trans Am WS6 A4

    Why does everyone want LEDs in their dashes? What's wrong with regular bulbs? You can't really dim an LED without a PWM controller...

  8. #8
    Junior Member BIG_MIKE2005's Avatar
    Join Date
    Jun 2006
    Location
    Skiatook, Ok
    Age
    34
    Posts
    75

    NBM
    1999 Trans Am WS6

    The LED gauges look great, thats why. I just got the map/dome lights from them along with new red LED's for my doors. They will be goin in shortly. Next up is the HVAC, cluster & headlight switch.

    Not sure how much he gets on here, but the owner is a regualr on tech.

  9. #9
    Junior Member
    Join Date
    Sep 2006
    Location
    Smithtown NY
    Age
    30
    Posts
    94

    White
    1999 T/A

    ill take a pic when i get the new bulbs but yea the blue looks GREAT in teh cluster. Who dims their cluster anyways???? lol

  10. #10
    Member
    Join Date
    Oct 2005
    Location
    Austin, Tx
    Age
    33
    Posts
    532

    Black/Black
    2000 Trans Am WS6 A4

    the leds really shouldn't look that much different than simple colored bulbs... but whatever floats your boat... I just don't like that you can't fade your dash lights once you switch over...

  11. #11
    Junior Member
    Join Date
    Sep 2006
    Location
    Smithtown NY
    Age
    30
    Posts
    94

    White
    1999 T/A

    you can still fade them.... mayb not as much to the effect of the bulbs. ive never seen them but if you know of somewhere to gett quality colored bulbs for the cluster please lmk.

  12. #12
    Member 99WS6MAN's Avatar
    Join Date
    Dec 2005
    Location
    TX
    Posts
    309

    Red
    99 Pontiac WS.6 Trans Am

    Quote Originally Posted by T/AKing View Post
    Several months ago i got a set of Blue LED cluster bulbs from ledgauges.com They all looked GREAT..... for about a month. soon after two of the bulbs died. this week a THIRD one that was dimming also Died AND the fourth one has been Flickering like a bitch lately. ive tried just about everything possible. i bend the brass clips in to get a tighter connection, i hot glued the bulbs in so they dont wiggle, and jsut about everything else. so im just curious...... Is there anyone out there who has been having similiar problems to me? ive been talkin to ledgauges guy to get some new bulbs but its a slow process, and as much as i hate to do it, im on the verge of going to the site and just ordering another set for 35 bux just so i can see my friggin cluster at night and because when they worked they looked VERY good. any ideas?

    also i put a video on youtube of the flickering bulb. you can also see in the middle of the cluster its very dim, and on the left and right the bulbs are normal color because after the other 2 died, i just put the stock ones in so i could see my gauges at night. so basically now ive got one working blue bulb.


    http://www.youtube.com/v/zbmrfWbKG5g
    (i just uploaded it so the vid will be ready in a couple)
    I have that problem with my Dome/ Map Lights ...the bulbs work for a good 3 or 4 months then die ....
    99 WS6 Trans AM
    Hurst Shifter
    Aftermarket Throttle Body
    KN Air Filter
    Strut Tower Brace
    Z06 Rims

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Dash / Instrument Cluster Bulbs
    By 01SsRacing in forum Appearance Section
    Replies: 11
    Last Post: 10-03-2012, 02:05 PM
  2. LED cluster bulbs
    By fbodyNATION in forum Stereo and Electronics
    Replies: 20
    Last Post: 05-14-2011, 07:29 PM
  3. Gauge Cluster Problems
    By JerseyLS1 in forum General Help
    Replies: 4
    Last Post: 04-15-2009, 07:43 PM
  4. Help: LEDGauges HID Install
    By LastHawk in forum Stereo and Electronics
    Replies: 4
    Last Post: 03-25-2009, 11:57 AM
  5. HVAC and Instament cluster problems
    By 98z2006 in forum Appearance Section
    Replies: 2
    Last Post: 04-26-2006, 01:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •