Results 1 to 4 of 4

Something doesn't seem right

This is a discussion on Something doesn't seem right within the GTO forums, part of the Vehicle Specific category; So I took my gto to get tuned after I put LTs and a cam on it(ls1) and only came ...

  1. #1
    Junior Member laviente's Avatar
    Join Date
    Sep 2006
    Location
    omaha,NE
    Age
    32
    Posts
    54

    Something doesn't seem right

    So I took my gto to get tuned after I put LTs and a cam on it(ls1) and only came out with 360hp to the wheels. Its a tx speed 228r cam and I have a k&n cai. I have 3" pipes coming off the headers straight to a spintech side exhaust. Do I have a shitty set up or is that the numbers I should be getting?

    Thanks in advanced
    Lavi

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    with the GTO's the temps that it was dyno'd at will make a big difference. They like to heat soak quite a bit. I personally would probably expect a few more HP there but not a ton on stock heads. Also, what did your car base dyno at? Try not to get too caught up in numbers......what matters is gains at the track. The dyno is just a tool.

  3. #3
    Junior Member laviente's Avatar
    Join Date
    Sep 2006
    Location
    omaha,NE
    Age
    32
    Posts
    54
    I've never taken it to the track. I'm in jax. The closest one is in gainsville. Idk the base dino either. I suck,lol

  4. #4
    Junior Member turismoGTO's Avatar
    Join Date
    Feb 2012
    Location
    GA,USA
    Posts
    9

    Turismo Blue
    2004 Pontiac GTO

    That seems right. Thats almost 60 more horses over factory with a cam that only produces 30-45 over then add in your headers and a tune. I put down 404rwhp with a tsp TV.2 cam,Lts,and open exhaust. It was over 80 in that shop and i live in south GA where there is always high humidity. I would suggest a 160* thermostat,UDP,and better intake.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. This guy doesn't get paid enough
    By Knight in forum Almost Anything Goes
    Replies: 15
    Last Post: 06-10-2010, 03:55 PM
  2. Who has em' Who doesn't?
    By Smkn_TA in forum Almost Anything Goes
    Replies: 39
    Last Post: 06-09-2010, 06:11 PM
  3. Sig doesn't tell the tale!
    By PFM in forum Request and Feedback
    Replies: 3
    Last Post: 08-08-2007, 08:19 AM
  4. It doesn't get much better than this...
    By SharkTA in forum Firebird / WS6
    Replies: 4
    Last Post: 02-19-2006, 02:01 PM
  5. car doesn't start
    By BlackTA00 in forum General Help
    Replies: 13
    Last Post: 09-16-2005, 09:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •