Results 1 to 6 of 6

Is this my clutch, fuel pump, or what?

This is a discussion on Is this my clutch, fuel pump, or what? within the GTO forums, part of the Vehicle Specific category; Ok so I have an '06 M6, and the few times Ive hard-launched it, it seems to be kinda gummed ...

  1. #1
    Member PatrizioD's Avatar
    Join Date
    Nov 2007
    Location
    The Anus of America; RI
    Posts
    381

    Nero
    2006 gto

    Is this my clutch, fuel pump, or what?

    Ok so I have an '06 M6, and the few times Ive hard-launched it, it seems to be kinda gummed up. Ive dealt with blown clutches before, so I dont think that is the problem, but Im an idiot and therefore most likely wrong. It seems like when I stomp the gas pedal and let off the clutch, it bogs down. Ive heard about the fuel pump not having enough capacity or something. I hope thats the problem, because I dont wanna replace the clutch yet... anyone else have this problem? The cars bone stock btw.

  2. #2
    rednari
    Guest
    Make sure the TC is off.

  3. #3
    doesn'tplaywellwithothers superchargedblackgto's Avatar
    Join Date
    Jan 2007
    Location
    Mayberry....(Indiana)
    Posts
    1,634

    Black
    2004 GTO

    A few things come to mind, Dirty TB, or a fuel issue....now your stock pump is fine...However, it could be a dirty fuel filter, plugged injectors.....I need more info....Such as how long have you had the problem, clutch should be fine, I would think unless you ride it ALL the time.....I suspect something easier than that....throttle would stick, because of gum from not having a catch can....give me milage are u the origional owner, does it do it ALL the time, just on hard launches?...get back to me with as much info as you got.

    Brad
    '04 gto M6 slp ceramic coated headers,B&m sport shifter,harrop cover,3.5"aluminum BMR driveshaft, BMR axle stubs, BMR Half shafts, BMR SFC's, loudmouth2 exaust,90mm FAST T/B,Magancharger(high helix upgrade)......other misc. suspension,Cross drilled, slotted rotors. Meth Kit, spraying @ 3psi and up

  4. #4
    Member PatrizioD's Avatar
    Join Date
    Nov 2007
    Location
    The Anus of America; RI
    Posts
    381

    Nero
    2006 gto

    Im the second owner, I bought it with 12k on it and its got just under 21k now. Ive had it happen about 4 or 5 times since I bought the car in November, and I've been driving stick's since I got my license 6 years ago...so I know how to work a clutch. It really only does it when I rev high and release the clutch. I did a burnout in a Dunkin Donuts parking lot a few weeks ago, TC was on so I screwed the pooch on that one, but Im pretty sure I didnt damage anything because as soon as I let off the clutch I realized it was still on and backed off. The second try worked a little bit, but I think I should be able to go a little further than 3 feet with ~330+ rwtq. Ill try it again today, and stick my digital camera on the dash to recordify a video of what happens. Thanks for the help...

  5. #5
    doesn'tplaywellwithothers superchargedblackgto's Avatar
    Join Date
    Jan 2007
    Location
    Mayberry....(Indiana)
    Posts
    1,634

    Black
    2004 GTO

    Quote Originally Posted by PatrizioD View Post
    Im the second owner, I bought it with 12k on it and its got just under 21k now. Ive had it happen about 4 or 5 times since I bought the car in November, and I've been driving stick's since I got my license 6 years ago...so I know how to work a clutch. It really only does it when I rev high and release the clutch. I did a burnout in a Dunkin Donuts parking lot a few weeks ago, TC was on so I screwed the pooch on that one, but Im pretty sure I didnt damage anything because as soon as I let off the clutch I realized it was still on and backed off. The second try worked a little bit, but I think I should be able to go a little further than 3 feet with ~330+ rwtq. Ill try it again today, and stick my digital camera on the dash to recordify a video of what happens. Thanks for the help...
    Like I said in the above post, Im guessing a fuel issue, or TC, will make the breaks in the back grab....are you getting violent wheel hop?....I really dont believe its the clutch....Im about 560bhp and My stock clutch just went from nasty launches @ the track.....
    Brad

  6. #6
    Member PatrizioD's Avatar
    Join Date
    Nov 2007
    Location
    The Anus of America; RI
    Posts
    381

    Nero
    2006 gto

    I havent had ANY wheelhop at all in the Goat. I agree that its probably not the clutch. Its definitely not the TC because I take it off first thing when I start up. Its gotta be somewhere in the fuel system. Im gonna order the LPE fuel pump and do the drill mod and see if that fixes the problem. Thanks for the help, Im soooo glad others concur that its probably not the clutch.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump fuel guage issues on my '02 B4C
    By ANDYZ28 in forum Camaro / SS
    Replies: 7
    Last Post: 12-29-2014, 11:30 AM
  2. Pontiac Fuel Pumps - Do You Have The Right Fuel Pump?
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 03-15-2011, 10:20 PM
  3. LS1 all yr fuel injectors, oe fuel rail, pump,more
    By Frost in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 04-27-2009, 03:26 PM
  4. Replies: 3
    Last Post: 10-02-2006, 07:23 PM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •