Results 1 to 5 of 5

GTO radio reception

This is a discussion on GTO radio reception within the GTO forums, part of the Vehicle Specific category; How is the antenna set up on GTO's? I was wondering because mine came with a pioneer AVIC-D1 (installed by ...

  1. #1
    Senior Member slims00ls1z28's Avatar
    Join Date
    Apr 2007
    Location
    TN
    Posts
    1,212

    2005 GTO M6 Black
    2000 Z28 A4 Red

    GTO radio reception

    How is the antenna set up on GTO's? I was wondering because mine came with a pioneer AVIC-D1 (installed by circut city from the paperwork in the glovebox) with XM and Nav etcm, but for some reason the regular radio stations pick up like $h!t. There is a possibility the maybe the factory antenna is not plugged up right (haven't messed with it yet), but I noticed while going through this there is no mast style and I didn't see anything on the winshield. What it is attached through just the chassis how well do they pick up?

  2. #2
    Senior Member GOT1GOAT's Avatar
    Join Date
    Sep 2006
    Location
    Newcastle,De.
    Age
    60
    Posts
    1,048

    04 GTO QuickSilver
    95 MarkVIII wifey white

    The antena is in the rear windshield with the defroster elements. I believe it's the one that runs up and down. I get 0 am reception (only tried it for traffic info) but my fm is excellant.

  3. #3
    Junior Member
    Join Date
    Sep 2007
    Location
    Orland Park IL
    Posts
    12

    Red
    04 Pontiac GTO

    even my FM is a little fuzzy now and then... and thats wit the stock Blathunkt 6 disk....


    James

  4. #4
    Member
    Join Date
    Jun 2007
    Location
    Annville PA
    Posts
    137

    silver
    2004 gto

    yeah my opinion is that i hate are radios there junk mine cuts out too and the disc skips for no reason a couple days ago i put a NEW CD in and it skipped after track 10 and put it in some buddies cobalt worked perfect like it never happened and it was the first time plus it never skip like 1-9 always the last tracks of the CD.

  5. #5
    Senior Member GOT1GOAT's Avatar
    Join Date
    Sep 2006
    Location
    Newcastle,De.
    Age
    60
    Posts
    1,048

    04 GTO QuickSilver
    95 MarkVIII wifey white

    James, you might have a broken antanae element in the back glass. give it a look see.

    SLP, something is wrong with your unit - loose or something because the cd player is all that I use and have never had a disc skip even over some hellasious bumps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help with reception
    By WHITE TA in forum Stereo and Electronics
    Replies: 1
    Last Post: 05-23-2012, 08:52 PM
  2. No Radio Reception
    By David Ray in forum Stereo and Electronics
    Replies: 2
    Last Post: 08-31-2009, 08:40 PM
  3. oem radio
    By Pete Rock98 in forum Parts For Sale / Trade
    Replies: 2
    Last Post: 03-09-2007, 12:16 PM
  4. Poor Monsoon Radio Reception
    By jimmi7769 in forum Stereo and Electronics
    Replies: 19
    Last Post: 01-16-2006, 07:34 AM
  5. Aftermarket Radio Reception
    By Thorinman in forum Stereo and Electronics
    Replies: 2
    Last Post: 12-27-2005, 08:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •