Results 1 to 5 of 5

Electrical Problems

This is a discussion on Electrical Problems within the GTO forums, part of the Vehicle Specific category; I am new to this board, anyways, I am the proud owner of a Torrid red/red 2004 GTO, No real ...

  1. #1
    Junior Member 04gtoman's Avatar
    Join Date
    Sep 2009
    Location
    Illinois
    Posts
    3

    torrid red
    2004 gto

    Question Electrical Problems

    I am new to this board, anyways, I am the proud owner of a Torrid red/red 2004 GTO, No real problems to date 51,000 miles until about a month ago. I would be driving and the accessories (radio, windows and a/c) would shut off, all at the same time, the radio would turn back on however, the windows would not operate until I turned the car off and completely removed the key from the ignition. On Sunday, I was driving and everything turned on, I mean everthing, horn, lights (all), windshield wipers and windows (went down). I have never seen such a thing, Initially I thought ignition lock (have it not replaced yet) maybe the ignition switch (electrical) or the voltage regulator. Given that I had to disconnect the battery to turn the lights off, kind of ommits the voltage regulator, given the car is not running.
    Any input, suggestions on past experience or ideas? I don't really want to pay a BUNCH of money to have someone diagnose to problem, then pay to have it fixed.
    A,

  2. #2
    Junior Member Mich's04's Avatar
    Join Date
    Aug 2007
    Location
    New York
    Age
    47
    Posts
    95

    Cosmos Purple
    2004 GTO M6

    I'm thinking that the BCM- Body Control Module might be on the fritz.

    It's located up under the glovebox. I'd have to look in my '04 shop manuals to see what functions the BCM controls. I know for fact it controls door lock function, because I had to wire the JHP door lock kit into the BCM. I'll see if I can find anything inthe manual later on.
    04 Cosmos Purple M6, SAP Grills & Spoiler, '05 Hood, Procharger, TrickFlow 515 HP H/C Kit, SLP LT Headers/LM II, '05 Big Red Brake upgrade, Drag bags, Holden CV8R wheels, GMM Ripshifter. Tuned by New Era: 515 rwhp/471 ft.lbs. Retuned by J&J Speed: Speed Density tuned 586rwhp/ 492 ft.lbs.

  3. #3
    Junior Member scauffiel's Avatar
    Join Date
    Jan 2009
    Location
    Chesapeake, VA
    Age
    47
    Posts
    42

    Carousel Red
    2005 Pontiac GTO

    Adam?? lol

    I sent you an email saying I found a thread over on LS2GTO where someone had the same issues and it turned out to be the low speed fan relay. Oddly enough.

    S.
    Steve
    2005 Carousel Red Twin Turbo GTO
    Click for full size
    My Garage

  4. #4
    Junior Member 04gtoman's Avatar
    Join Date
    Sep 2009
    Location
    Illinois
    Posts
    3

    torrid red
    2004 gto

    Quote Originally Posted by scauffiel View Post
    Adam?? lol

    I sent you an email saying I found a thread over on LS2GTO where someone had the same issues and it turned out to be the low speed fan relay. Click for full size Oddly enough.

    S.
    Hey brother, Wasn't the low speed fan relay, oddly enough I just changed the high fan relay just before the issues began, HMMM! Well, I'll keep searching, going to take it to the shop after the bells and whistles on the 17th!! lol

  5. #5
    Junior Member 04gtoman's Avatar
    Join Date
    Sep 2009
    Location
    Illinois
    Posts
    3

    torrid red
    2004 gto

    Thanks man, I haven't had any real issues until I changed the high fan relay. Then it all wnet down hill! Maybe a correlation maybe not?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical problems
    By c5z28 in forum General Help
    Replies: 3
    Last Post: 01-29-2012, 08:34 PM
  2. Question: Electrical problems:
    By Camaro1994 in forum General Help
    Replies: 5
    Last Post: 10-03-2009, 05:25 PM
  3. Electrical Problems
    By bryceslu in forum Firebird / WS6
    Replies: 6
    Last Post: 11-01-2007, 10:51 AM
  4. A few electrical problems.
    By xinthenight in forum General Help
    Replies: 2
    Last Post: 09-22-2007, 10:18 PM
  5. electrical problems, need help
    By MaxPlusTen in forum LT1
    Replies: 1
    Last Post: 05-23-2007, 06:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •