Results 1 to 10 of 10

"Check Oil" Displayed

This is a discussion on "Check Oil" Displayed within the GTO forums, part of the Vehicle Specific category; Hello All, Having an issue with a "Check Oil" message.... Not sure what to do???.... This is on my 2005 ...

  1. #1
    Junior Member The Hulk's Avatar
    Join Date
    Jul 2008
    Location
    Milwaukee, WI
    Age
    51
    Posts
    11

    Phantom Black Metallic
    2005 GTO

    "Check Oil" Displayed

    Hello All,

    Having an issue with a "Check Oil" message.... Not sure what to do???.... This is on my 2005 GTO....
    Oil level is good... message seems to be intermittent.... Sometimes goes off frequently.... sometimes not at all.... Have been told it is a faulty sensor but need more info.... I know this is not a good message, but am not sure if this means there is a problem with oil pick-up in the oil pan, if sensor is bad, or if there is another problem I am not aware of.... Plz help!

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Your pressure sender is on its way out. Are you getting an actual "CHECK OIL" light? Or are you getting the "SERVICE VEHICLE SOON" light? I know when my oil pressure sender went I got the "SERVICE VEHICLE SOON" light and scanned the car at my job and got a low voltage code. Ordered/replaced the sender and all is peachy.


    extreme dimensions, driveshaft shop, harrop, hid(35watt/6k) lows, hurst, k&n, led fogs, maverick man, mishimoto, nitto, revshift, slp, stern st-1, smoked sidemarkers, whiteline poly radius rod bushings

  3. #3
    Junior Member The Hulk's Avatar
    Join Date
    Jul 2008
    Location
    Milwaukee, WI
    Age
    51
    Posts
    11

    Phantom Black Metallic
    2005 GTO

    It's actually a "Chech Oil" message in the display.... Also, when searching for parts I'm finding two different types of sensors... on looks like a post that goes into the oil pan (two prong) and the other looks like a plug with a hole on the oil pan side (three prong).... is there a difference (other than the obvious) or will either work?.....

  4. #4
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    One might be for a gauge and the other for a light on the dash or level in the pan. Have you scanned the car at all?

  5. #5
    Junior Member The Hulk's Avatar
    Join Date
    Jul 2008
    Location
    Milwaukee, WI
    Age
    51
    Posts
    11

    Phantom Black Metallic
    2005 GTO

    No... Not yet.... Just got the scanner n haven't had chance yet... will do it tomorrow after work.... friend of mine has an '06 Goat he wants to scan as well...
    Last edited by The Hulk; 02-04-2010 at 09:09 PM.

  6. #6
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Have you ever reset your change oil timer thing doohickey? You know the gas pedal three times real fast process?

  7. #7
    Junior Member The Hulk's Avatar
    Join Date
    Jul 2008
    Location
    Milwaukee, WI
    Age
    51
    Posts
    11

    Phantom Black Metallic
    2005 GTO

    Yes... Actually have done that several times (as the message comes up)...

  8. #8
    Junior Member Mich's04's Avatar
    Join Date
    Aug 2007
    Location
    New York
    Age
    47
    Posts
    95

    Cosmos Purple
    2004 GTO M6

    Do you have an oil pressure gauge installed on the car? The reason I ask is if for some reason you replace all the sensors and such and the Check Oil indicator still chimes at you. There may be an issue with the oil pump taking it's sweet time building pressure when you first start the engine.

    I had the Check Oil indicator issue drive me nuts for awhile on my '04. I'd check the level. It would be fine. So I ignored it for the longest time. Sometimes I blip the gas pedal right after it fired up and there was no annoying Check Oil indicator. So after I installed the oil pressure/volt gauge kit into the car, I noticed the oil pressure took a long time to come up. So I replaced the oil pump along with many other goodies and that cured the problem for my situation.

    Hopefully your issue is a sensor. But if not you know where else to look now.
    Good luck!
    04 Cosmos Purple M6, SAP Grills & Spoiler, '05 Hood, Procharger, TrickFlow 515 HP H/C Kit, SLP LT Headers/LM II, '05 Big Red Brake upgrade, Drag bags, Holden CV8R wheels, GMM Ripshifter. Tuned by New Era: 515 rwhp/471 ft.lbs. Retuned by J&J Speed: Speed Density tuned 586rwhp/ 492 ft.lbs.

  9. #9
    Junior Member The Hulk's Avatar
    Join Date
    Jul 2008
    Location
    Milwaukee, WI
    Age
    51
    Posts
    11

    Phantom Black Metallic
    2005 GTO

    Hello All,

    Just wanted to say thanks to all for your suggestions on my problem.... I have replaced the "Oil Pressure Sensor" on my car and this solved the problem..... Again, Thanks to all for your help and suggestions.....

  10. #10
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Glad to hear. Enjoy your car.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. So, the Regime Wants a Blank Check to Fight "J.V." Team ISIS
    By wileyCoyote in forum Political / Debate Forum
    Replies: 2
    Last Post: 12-11-2014, 06:07 AM
  2. Question: "Check Gages" light flickering on and off
    By pdiddyz28 in forum General Help
    Replies: 8
    Last Post: 08-06-2010, 04:06 PM
  3. Grand Prix GT "check engine light"
    By rschap1 in forum Almost Anything Goes
    Replies: 3
    Last Post: 10-24-2008, 07:20 PM
  4. "Check Gauges" light on, how much fuel is left?
    By amon37 in forum General Help
    Replies: 10
    Last Post: 01-14-2007, 07:29 PM
  5. check out nothingface's new song "walking on bodies"
    By Ice Spiral in forum Almost Anything Goes
    Replies: 5
    Last Post: 07-30-2006, 07:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •