Results 1 to 7 of 7

Air Bag Fault

This is a discussion on Air Bag Fault within the GTO forums, part of the Vehicle Specific category; I had removed the passenger side seat to do some work in the console and under the dash. I put ...

  1. #1
    Junior Member Mich's04's Avatar
    Join Date
    Aug 2007
    Location
    New York
    Age
    47
    Posts
    95

    Cosmos Purple
    2004 GTO M6

    Air Bag Fault

    I had removed the passenger side seat to do some work in the console and under the dash. I put the seat back in and reconnected the Air bag and power harnesses. Then I hooked the battery back up. Started the car, and now the Air Bag Fault light is on. WTF!!!

    So what do I need to do to reset the system or fix it?
    04 Cosmos Purple M6, SAP Grills & Spoiler, '05 Hood, Procharger, TrickFlow 515 HP H/C Kit, SLP LT Headers/LM II, '05 Big Red Brake upgrade, Drag bags, Holden CV8R wheels, GMM Ripshifter. Tuned by New Era: 515 rwhp/471 ft.lbs. Retuned by J&J Speed: Speed Density tuned 586rwhp/ 492 ft.lbs.

  2. #2
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Sorry man but you gotta take it to the dealer.....I have a scanner and can do it.....is there anybody around you with a scanner? Other than that...with the battery disconnected first....I cant see how in the hell it did it.....

  3. #3
    Junior Member Mich's04's Avatar
    Join Date
    Aug 2007
    Location
    New York
    Age
    47
    Posts
    95

    Cosmos Purple
    2004 GTO M6

    Thanks Sarge.
    I was afraid I was going to have to make a visit with the dealer.
    I don't understand either why the light is on. I never had a problem with air bag stuff on any vehicle. I even grounded myself before touching the connector. Oh well. Sh!t happens I guess.

  4. #4
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    You know I always disconnect the battery then turn the key on and hit the brakes to discharge all the juice in the system ( see capacitors).....well that sucks man.....sorry to hear you gotta go to the dealer....but a warning light makes me fucking crazy

  5. #5
    Junior Member Mich's04's Avatar
    Join Date
    Aug 2007
    Location
    New York
    Age
    47
    Posts
    95

    Cosmos Purple
    2004 GTO M6

    Well I called up a guy at Goodyear that we do bizz with and ask if he could scan the system for me. He hooked up their big fancy SnapOn scanner and 3 codes showed up for all of about 3 seconds then dissappeared from the screen. Then it displayed "No Codes Present." WTF!!!!
    So I guess it's off to the dealer this week.

    Did you ever hear of this senario happening?

  6. #6
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Yeah...it is a specific code and you must have a specific reset capability for the air bag....

  7. #7
    Junior Member Mich's04's Avatar
    Join Date
    Aug 2007
    Location
    New York
    Age
    47
    Posts
    95

    Cosmos Purple
    2004 GTO M6

    Ok, that is somewhat of a relief.
    Now let me ask you this...do I have to go to a Pontiac dealer or can a Chevy dealer perform this procedure also?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. It's the Tea Party's fault....
    By Frosty in forum Political / Debate Forum
    Replies: 4
    Last Post: 08-07-2011, 10:09 PM
  2. '05 airbag fault???
    By Fester801 in forum GTO
    Replies: 2
    Last Post: 03-04-2011, 09:37 PM
  3. Was that my fault?
    By FSANE in forum Almost Anything Goes
    Replies: 36
    Last Post: 06-06-2010, 05:51 PM
  4. Question: Anyone else have a recurring ABS fault?
    By 5.7literMustangEater in forum GTO
    Replies: 9
    Last Post: 01-22-2009, 05:17 AM
  5. It is Bush's Fault!
    By Sarge in forum Political / Debate Forum
    Replies: 10
    Last Post: 02-17-2006, 10:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •