Page 2 of 5 FirstFirst 12345 LastLast
Results 21 to 40 of 92

04' GTO front mount TC78 LQ4

This is a discussion on 04' GTO front mount TC78 LQ4 within the GTO forums, part of the Vehicle Specific category; subscribed... Lookin good...

  1. #21
    Junior Member 383T/A's Avatar
    Join Date
    Dec 2010
    Location
    LJC
    Posts
    30

    white
    2000 trans am vert.

    subscribed... Lookin good

  2. #22
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    Thanks bro, I got some piping back yesterday, new timing cover with bung welded in for oil return, so im in the middle of final mock up.

    Need to figure out how im gonna do the wastegate then i should be ready to rock this bitch out. I test fit the radiator and lines for that, i was very happy they all fit ok.

    Tightened down the motor mounts, bolted the manifolds back on with gaskets for the final time.

    im hoping to get the wastegate plumbed tomorrow, then its onto the cold side and putting the radiator brackets back on. i hope to atleast have a couple pics by sunday afternoon.

  3. #23
    Junior Member 383T/A's Avatar
    Join Date
    Dec 2010
    Location
    LJC
    Posts
    30

    white
    2000 trans am vert.

    That's great ... Now, how much have you got invested in the project so far. If you don't mind me asking... I'm all fired up for ya, now

  4. #24
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    lol, i would way just over 3k total.

    i was right at like 2900 last week before i paid a local fabricator 140 bucks for some tig welding on different things.

    ive probably got another 200 bucks to spend though, i know ill need some more silicone and ic piping, and have to get coolant, plugs and oil. ive got all the other fluids already.

  5. #25
    Junior Member 383T/A's Avatar
    Join Date
    Dec 2010
    Location
    LJC
    Posts
    30

    white
    2000 trans am vert.

    Very nice... Ok, i'm still watchin' you.

    Happy New Year...

  6. #26
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    Well, thanks to so motivation by Rossko85 last night i got my ass today and decided to do some more work.

    I was originally going to plumb my wastegate into my down pipe, and even cut and shaped the metal to make that happen, Thought it looked very nice as well.

    But after much though, i decided, i liked knowing that my wastegate is opening and i like the sound. so im going with the old open dump.

    Furthmore, i was able to all but complete my battery relocate yesterday with the help of rossko, so today i decided i would go ahead and run the positive cable to the front, i got some outdoor electrical conduit from home depot, its gray in color, lol. very rigid shit, it was not easy fishing it behind my some shit in the rear of the car. but overall im happy with it, it follows the exact same path my return oil followed for the rear mount.

    well, onto the pics i suppose, just 3 today.






  7. #27
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    With your battery relocated....get a grounding strap and ground your engine block to your frame. Trust me on this one.

  8. #28
    Member Texas Jack's Avatar
    Join Date
    Jul 2008
    Location
    Central Texas
    Posts
    675

    Cyclone Grey
    2006 GTO M6

    Looking good!!

  9. #29
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    Thanks sarge, i was thinking the same, i read your relocate thread, and basically bought what you did, my conduit is different because i couldnt find the blue shit at HomeDepot, lol.

    This stuff is nice though, very tough. Should work well.

    thanks for the compliments

  10. #30
    Universal Pisser Offer Fester801's Avatar
    Join Date
    Oct 2009
    Location
    Grapevine, TX
    Posts
    105

    Torrid Red
    05 GTO M6

    subscribed... Looking good!!

  11. #31
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    Well got all my wiring done, and hooked up the battery, KEY-ON and ive got lights and dings and all kinds of pretty sounds

    bumped the starter just to see and nothing arg!

  12. #32
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    looks like your geting closer,make sure all your grounds are connected there are several on our cars the one that went under the air conditioning pump has to be grounded if not you will not get the car to even turn over,its easy to leave that one off .you cant see it unless u look under the car.also must have the shifter module plugged in ( the one that goes onto the side of the trans) will do the same thing.kapoots..

  13. #33
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    Quote Originally Posted by qwkgto View Post
    looks like your geting closer,make sure all your grounds are connected there are several on our cars the one that went under the air conditioning pump has to be grounded if not you will not get the car to even turn over,its easy to leave that one off .you cant see it unless u look under the car.also must have the shifter module plugged in ( the one that goes onto the side of the trans) will do the same thing.kapoots..
    Im gonna crawl under their tonight and see if i missed it, because i tried the other night to bump the key and nothing happened with the starter, all the little lights and buzzers and all the frilly shit came on, but i was thinking i missed one somewhere,

    I didnt get a clear answer earlier, but does the alternator ground internally or is there and actual ground wire for it coming off it??

    I keep forgetting to look when im down their. But nothing sticks out at me.

    I did however trace the wires the other night, and didnt notice one, it appears that what could be ground the (black wire running next to power wire for starter) splices into a purple wire and goes to a clip up by the fuses and all that jazz.

    I dont know.

  14. #34
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    I beleive the alt has just the one wire,plus the GM plug think its grounded that way,im betting you left off the ground near the air unit,its way up under there easily missed, it actually bolts to the bracket that bolts to the block then the air compressor unit bolts ontop of it,did the same thing once tucked it back outa the way ,to forget it once I had motor back in the car.

  15. #35
    Junior Member thedak's Avatar
    Join Date
    Dec 2009
    Location
    Pittsburgh, PA
    Posts
    13

    BOM
    2006 Pontiac GTO

    Pics of this ground wire by the AC compressor ?

  16. #36
    Member JAX04's Avatar
    Join Date
    Mar 2009
    Location
    indianapolis
    Posts
    471

    PBM 366ci TC78 E85
    2004 Pontiac GTO PBM A4

    Qwk. I'm really not seeing something I missed bro. I don't have the AC anymore and can't see anything under their I might have missed.

    This ground u speak of, is it a block ground? Or a ground for something important?

    Also, can someone go into the secret menu and tell me what ur voltage reads?? Or does anyone know what the minimum startup voltage is?

    I'm going to be trying for the first tomorrow I think and want to make sure my battery isn't dead. All my lights and shit come on but it says security blah blah see dealer on the dash display.

    Feel free to shoot me a pm if u want to call or something maybe someone can talk me through some trouble shooting. Qwk we've talked on the phone close to a year ago. I remember u telling me stories about ur front mounts at That time.

    Sent from my Droid using Tapatalk
    2004 GTO,A4 turbo build in the progress and corn juice to follow

  17. #37
    Junior Member thedak's Avatar
    Join Date
    Dec 2009
    Location
    Pittsburgh, PA
    Posts
    13

    BOM
    2006 Pontiac GTO

    Last edited by thedak; 02-27-2011 at 09:02 PM.

  18. #38
    Member Texas Jack's Avatar
    Join Date
    Jul 2008
    Location
    Central Texas
    Posts
    675

    Cyclone Grey
    2006 GTO M6

    Jax, Sounds like your battery may be low. Gto's are very sensitive to voltage and amps, and many low batteries have caused lots of problems, make sure it is very hot and ready to go, hate to see you struggle over a low battery!

  19. #39
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    Quote Originally Posted by thedak View Post
    I know of no ground wire near the AC Compressor.
    well that does not surprise me since you have no idea what its like to work on your own car,that ground is there on the 05 -06 Goats

  20. #40
    Junior Member thedak's Avatar
    Join Date
    Dec 2009
    Location
    Pittsburgh, PA
    Posts
    13

    BOM
    2006 Pontiac GTO

    Quote Originally Posted by qwkgto View Post
    well that does not surprise me since you have no idea what its like to work on your own car,that ground is there on the 05 -06 Goats
    I pay a guy to wax it for me too.

Page 2 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Front Mount Turbo Systems
    By irocandroll4ws6 in forum Forced Induction
    Replies: 2
    Last Post: 05-23-2011, 01:51 PM
  2. 04' GTO front mount TC78 LQ4
    By JAX04 in forum Forced Induction
    Replies: 5
    Last Post: 01-23-2011, 10:37 AM
  3. Help: Help me move my rear mount up front.
    By Texas_WS6 in forum Forced Induction
    Replies: 8
    Last Post: 04-07-2010, 06:41 PM
  4. Help: Newbie wants to do front mount turbo
    By need4speed069 in forum Forced Induction
    Replies: 15
    Last Post: 11-21-2009, 05:20 PM
  5. New front mount truck kit-finished
    By farmtruc in forum GM Trucks
    Replies: 1
    Last Post: 04-17-2007, 11:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •