Results 1 to 16 of 16

New Camaro SS Transmission Failure.....

This is a discussion on New Camaro SS Transmission Failure..... within the Kill Stories forums, part of the Racing Forums category; Apparently, the manual transmission can't take the power under hard launches... Uh oh............ http://www.autoblog.com/2009/07/13/b...ures-reported/ Seems to be a problem with ...

  1. #1

    New Camaro SS Transmission Failure.....

    Apparently, the manual transmission can't take the power under hard launches...

    Uh oh............

    http://www.autoblog.com/2009/07/13/b...ures-reported/

    Seems to be a problem with the input shaft failing. Probably be fixed in the next years model.

  2. #2
    Senior Member big hammer's Avatar
    Join Date
    Nov 2007
    Location
    manitoba, canada
    Posts
    1,731

    silver
    2002 ws6

    apparently they consulted nissan about this problem, given their recent experience in this field. the correction to this problem was simple. de-rate the power, and void the warranty if the engine ever goes to WOT. done and done!

  3. #3
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    hmm, i didnt know they had launch control and i dont see why it is breaking, its a tr6060 right?

  4. #4
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    It'll get fixed, not too worried about it, and yes they do have launch control, it works beautifully and will not void your warranty.

  5. #5
    Senior Member
    Join Date
    Mar 2009
    Location
    Milwaukee
    Posts
    3,260

    Arctic White, red/gray
    1997 Corvette, 92 Typhoon

    Quote Originally Posted by blue02Z View Post
    hmm, i didnt know they had launch control and i dont see why it is breaking, its a tr6060 right?
    Yes but that version is only rated to 430trq apparently.

  6. #6
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Not sure how that can be when it's used in the shelby gt500 and z06

  7. #7
    Senior Member
    Join Date
    Mar 2009
    Location
    Milwaukee
    Posts
    3,260

    Arctic White, red/gray
    1997 Corvette, 92 Typhoon

    Quote Originally Posted by allbaugh_04 View Post
    Not sure how that can be when it's used in the shelby gt500 and z06
    Different version of the same tranny apparently

  8. #8
    COTM July '09
    Join Date
    Jun 2008
    Location
    Annapolis, MD
    Posts
    1,111

    BLK/BLK w/CGM Stripes
    2010 Camaro 2SS/M6

    Quote Originally Posted by big hammer View Post
    apparently they consulted nissan about this problem, given their recent experience in this field. the correction to this problem was simple. de-rate the power, and void the warranty if the engine ever goes to WOT. done and done!
    LOL GOOD ONE. If a muscle car can't launch using all it's available over, that good is it? GM will do the right thing it seems.

  9. #9
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    51
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    It is a problem with the tranny vendor with defective shafts, just makes GM look bad.

  10. #10
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by Zinergy View Post
    Different version of the same tranny apparently
    correct... just like our t56's... fbodys have pieces of shit paper parts inside... vettes and vipers have stronger internals in thiers...

  11. #11
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    crap did they put an EVO trans in there?

  12. #12
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by Zinergy View Post
    Yes but that version is only rated to 430trq apparently.
    Yes that is true,,,,because for some stupid reason GM put a 3.01 first gear in there. Would have been better off and more durable if they stuck with something in the 2.5 to 2.6 range.

  13. #13
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by allbaugh_04 View Post
    Not sure how that can be when it's used in the shelby gt500 and z06
    Well it's not exactly the same. The shelby GT500 didn't get the 3.01 first gear that GM is sticking in the new camaro.

    Ford also stuck the same 6 speed GT500 tranny in the 50 factory cobra jet race cars they made,,,and that didn't fare too well either. I was talking to an R&D man for Centerforce clutches, who was given one of these factory racers to design a clutch for. He was at the track making passes and after a few passes the tranny was junk, from then on he never got outta first gear.
    He and I both wondered why Ford just didn't stick a nice jerico 4 speed in there from the get go. Cost being the biggest factor most likely.

    But if you watch any stock or super stock NHRA racing you'll see that one of these cars actually won class this year,,and the owner right off the bat saw fit to pull that 6 speed and drop in a Jerico before entering NHRA competion. Evidently it was a smart move.

  14. #14
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Just something I heard...good info. Always knew the 500 was shit

  15. #15
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by allbaugh_04 View Post
    Just something I heard...good info. Always knew the 500 was shit
    I like the GT500's,,,but I can't believe Ford stuck the same 6speed in the cobra jet race cars,,,a car that has no serial number and will never be destined or licensed for the street...pretty stupid tranny for that if you ask me. Funny though how they went through the trouble to setup the suspension to hook with a solid rear axle running a 9 inch ford no less....then they stuck that damn 6speed in it,,almost like ford kinda got lost with the purpose of the car in the middle of the build

  16. #16
    Member zmg00camaross's Avatar
    Join Date
    Oct 2008
    Location
    missouri
    Posts
    764

    pewter
    2000 camaro ss

    Well I guess gm will fix this. But what about 4th gens 10 bolts they should have warranty that and said hey here is your free 12 bolt. O you want a 9 inch ok here you go free $2500 rearend

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Camaro SS Transmission Issue: Help!
    By planesvscars in forum Automatic Transmission
    Replies: 3
    Last Post: 01-18-2017, 04:08 PM
  2. 1994 Camaro Z28 Transmission mount
    By 94camaroZ28 in forum General Help
    Replies: 9
    Last Post: 08-16-2011, 12:43 PM
  3. Fifth Gen Camaro Parts Failure - Got a '10-'11 Camaro? Here'
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 1
    Last Post: 07-22-2011, 08:05 AM
  4. Fifth Gen Camaro Parts Failure - Got a '10-'11 Camaro? Here'
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 0
    Last Post: 06-14-2011, 08:40 PM
  5. For Sale: rebuilt transmission (4l60e) out of 95 z28 camaro
    By SexyTransAm in forum Parts For Sale / Trade
    Replies: 3
    Last Post: 07-25-2009, 08:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •