Results 1 to 6 of 6

Top going up veeeeery slow!

This is a discussion on Top going up veeeeery slow! within the Convertible forums, part of the Vehicle Specific category; Have a strange problem w/ my 2000 SS's top going up. The top goes down fine, but when I go ...

  1. #1
    Junior Member
    Join Date
    Aug 2007
    Location
    saginaw MI
    Posts
    98

    Blue
    2000 Camaro SS Convertibl

    Post Top going up veeeeery slow!

    Have a strange problem w/ my 2000 SS's top going up. The top goes down fine, but when I go to raise it it goes up about 6 inches stops dead, I then lower and raise it again and it goes up all the way, but very slowly.
    I also hear a weird soft hissing noise for about 5 seconds near the back. This has gone on since I bought the car used over a year ago, and it has'nt gotten any worse so I'm not monkying with it...was just curious if anyone had any ideas what's up with this. Thanks!

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    It could need some fluid or the pump is on its way out. Check the level. How about the pivots, they might need a little grease.

  3. #3
    Member slikws6's Avatar
    Join Date
    Feb 2008
    Location
    southeast
    Posts
    136

    Black
    1998 WS6 Convert

    Yea what he said

  4. #4
    Member Z ROADSTER's Avatar
    Join Date
    Mar 2007
    Location
    Shreveport,Louisiana .USA
    Posts
    505

    PEWTER
    2002 Z/28 VERT.

    Let us know the cure !

  5. #5
    Junior Member
    Join Date
    Aug 2007
    Location
    saginaw MI
    Posts
    98

    Blue
    2000 Camaro SS Convertibl

    Thanks guys. Never posted too much on the convertible thread before... but I'm impressed with the feedback so far.
    It's awesome to get so much response with convertible enthusiasts regardless of their model.

  6. #6
    Member BlackSS1's Avatar
    Join Date
    Jun 2007
    Location
    Lexington, NC
    Posts
    460

    Black
    2001 Camaro SS Vert

    Quote Originally Posted by bigrondownhiller View Post
    It could need some fluid or the pump is on its way out. Check the level. How about the pivots, they might need a little grease.
    I agree, since the system is hydraulic the fluid may be low and need topping off. The vert top motors are notorious for slow leaks (mysterious oil spots on the driveway/garage floor near the rear wheel). Search the forum for types of fluid, there are different suggestions about what type is best. good luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slow top
    By SoWazIt2You in forum Convertible
    Replies: 3
    Last Post: 05-19-2010, 10:00 AM
  2. slow 5.0
    By Badass WS6 in forum Kill Stories
    Replies: 45
    Last Post: 04-05-2010, 12:18 PM
  3. Is my 99 z28 slow?
    By leejr85bmw in forum Drag Racing
    Replies: 12
    Last Post: 05-09-2008, 03:27 PM
  4. LS1's are slow
    By alex16 in forum Kill Stories
    Replies: 21
    Last Post: 10-17-2006, 03:01 PM
  5. Another slow lt1
    By juicedimpss in forum New Member Introductions
    Replies: 3
    Last Post: 09-01-2006, 07:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •