Results 1 to 4 of 4

Slow top

This is a discussion on Slow top within the Convertible forums, part of the Vehicle Specific category; Ok so now that winter is over and im driving my camaro around again I have noticed that my top ...

  1. #1
    Junior Member SoWazIt2You's Avatar
    Join Date
    Aug 2008
    Location
    Long Island, NY
    Posts
    5

    Black
    98 z28 'vert

    Slow top

    Ok so now that winter is over and im driving my camaro around again I have noticed that my top is getting pretty slow when trying to put it back up. Hopefully its not the motor thats going, but if it is has anyone ever replaced it? Is it a PITA to do yourself? Whats is involved? Anyone else have any ideas as to what else it could be? Any help would be appreciated.

  2. #2
    caraholic ggino85's Avatar
    Join Date
    Jul 2007
    Location
    most miserable city in the US
    Age
    32
    Posts
    568

    blue green chameleon
    1998 Trans Am

    The 02' SS i had did this, the fluid in the pump was low, i would try checking that first. The reservior is the rear(trunk) of the car under the panel that covers the rear left speaker. Opposite the spare in the trunk. Check it and if its low i think i used mineral oil to fill mine, once i filled it to the proper level the top started moving faster almost instantly...... also I think the check and fill procedure is in the owners manual.
    Last edited by ggino85; 05-05-2010 at 10:19 PM.

  3. #3
    Junior Member SoWazIt2You's Avatar
    Join Date
    Aug 2008
    Location
    Long Island, NY
    Posts
    5

    Black
    98 z28 'vert

    Ok thanks for the idea i will have to check it in the morning.

  4. #4
    Junior Member mrc54's Avatar
    Join Date
    May 2009
    Location
    Indiana
    Posts
    27

    silver
    2002 Z28 Convertible 4A

    There is a bleed off valve for manual top movement. Mine was not tight, causing slow top movement. It's located left side of trunk, by the pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slow 5.0
    By Badass WS6 in forum Kill Stories
    Replies: 45
    Last Post: 04-05-2010, 12:18 PM
  2. Got Slow!
    By InEEdSPEED in forum Camaro / SS
    Replies: 12
    Last Post: 03-11-2010, 05:29 AM
  3. why is my ws6 so slow???
    By 98ws6-girl in forum Firebird / WS6
    Replies: 46
    Last Post: 08-16-2007, 07:22 AM
  4. Wow Slow day here...
    By RoysTransAM in forum Rocky Mountain Members
    Replies: 28
    Last Post: 12-24-2006, 10:42 PM
  5. why is ls1.com so slow?
    By sgt0704 in forum Request and Feedback
    Replies: 90
    Last Post: 06-04-2006, 11:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •