Results 1 to 1 of 1

'97 TA, running, LT1/T-56, 10-bolt, Frame Damage

This is a discussion on '97 TA, running, LT1/T-56, 10-bolt, Frame Damage within the Vehicles For Sale / Trade forums, part of the Sponsors Group Pricing and Parts Review category; SOLD!!!...

  1. #1
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287
    iTrader
    0

    '12 Silver SS 1SS
    '00 Black SS #8617

    '97 TA, running, LT1/T-56, 10-bolt, Frame Damage

    SOLD!!!
    Last edited by SSwt00SS; 12-31-2008 at 11:19 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. frame damage questions
    By Ieatstangs in forum General Help
    Replies: 12
    Last Post: 04-04-2014, 07:13 AM
  2. SLP Bolt in Sub Frame Conectors
    By BRICKYARDDTX in forum Suspension and Handling
    Replies: 3
    Last Post: 06-05-2011, 06:24 PM
  3. For Sale: 2002 Z06 Crashed - Frame Damage
    By jcamere in forum Vehicles For Sale / Trade
    Replies: 15
    Last Post: 05-02-2009, 04:32 AM
  4. 2002 Yukon 2wd Complete Rolling Frame For Sale - No Damage !
    By LS1W in forum Parts For Sale / Trade
    Replies: 1
    Last Post: 05-14-2007, 08:25 PM
  5. 2000 frame damage question
    By jinxeng in forum General Help
    Replies: 4
    Last Post: 06-24-2006, 06:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •