Results 1 to 8 of 8

where is the Coolant Level Sensor?

This is a discussion on where is the Coolant Level Sensor? within the LT1 forums, part of the Vehicle Specific category; the light that says i have low coolant is on. and i dont have low coolant, i know this cause ...

  1. #1
    Trans Am for life baby SexyTransAm's Avatar
    Join Date
    Feb 2007
    Location
    E-town, Kentucky
    Age
    31
    Posts
    344

    95-black & 80-blue
    95 Trans Am and 80 TA

    where is the Coolant Level Sensor?

    the light that says i have low coolant is on. and i dont have low coolant, i know this cause i have looked many times. and i cant find the damn sensor. and i kinda like to put a new 1 in. any info would be great!!! thanks


    95 TA A4, Black on Black C5 Z06 wheels, CAI, 160 powerstat, TB coolent bypass, TB foil, LT4 Knock Sensor, STB, SFC, Poly trans and torque arm mounts, flowmaster muffler, gutted cat, and hypertech tuned.
    http://www.fquick.com/SexyTransAm

  2. #2
    Senior Member KyleLs1's Avatar
    Join Date
    Aug 2005
    Location
    Canada eh
    Posts
    3,534

    NBM
    99 TA

    i know on the ls1 cars it is right behind the top of the rad on the pass side, not sure if lt1 cars are the same or not

    btw when you find it... just disconnect it and leave it.
    they always go bad, not worth replacing imo.
    As long as you check it regularily, no need for the sensor

  3. #3
    Trans Am for life baby SexyTransAm's Avatar
    Join Date
    Feb 2007
    Location
    E-town, Kentucky
    Age
    31
    Posts
    344

    95-black & 80-blue
    95 Trans Am and 80 TA

    Quote Originally Posted by KyleLs1 View Post
    btw when you find it... just disconnect it and leave it.
    they always go bad, not worth replacing imo.
    As long as you check it regularily, no need for the sensor
    its been this way for a while now. and i would just leave it but i dont like the light bein on

  4. #4
    Senior Member KyleLs1's Avatar
    Join Date
    Aug 2005
    Location
    Canada eh
    Posts
    3,534

    NBM
    99 TA

    Quote Originally Posted by SexyTransAm View Post
    its been this way for a while now. and i would just leave it but i dont like the light bein on
    if you disconnect it the light will go out!

  5. #5

  6. #6
    Trans Am for life baby SexyTransAm's Avatar
    Join Date
    Feb 2007
    Location
    E-town, Kentucky
    Age
    31
    Posts
    344

    95-black & 80-blue
    95 Trans Am and 80 TA

    so the light will really go out if i just unplug it?

  7. #7
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    It does on the LS1 cars that have it for sure, disconnect the plug and zip tie it out of the way and see.

  8. #8
    Junior Member
    Join Date
    Jun 2007
    Location
    Minot AFB, ND
    Posts
    35

    Red
    01 Camaro SS & 1995 T/A

    It is on the bottom right of the water pump housing....easy to unscrew and replace...it solved my problems.....just get a towel ready for drips.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Coolant reservoir level goind down but no physical leak?
    By JayTA98 in forum General Help
    Replies: 10
    Last Post: 01-28-2014, 03:41 PM
  2. Coolant level sensor
    By fury78 in forum General Help
    Replies: 13
    Last Post: 09-12-2009, 07:01 AM
  3. 99 f-body coolant level sensor removal; HOW TO?
    By 99'CajunFirehawk157 in forum General Help
    Replies: 3
    Last Post: 01-06-2008, 11:14 AM
  4. Coolant light...coolant level full.
    By SR71 in forum General Help
    Replies: 4
    Last Post: 01-08-2007, 10:35 AM
  5. Coolant Level Light 1998 T/a
    By 332camarob4c in forum General Help
    Replies: 3
    Last Post: 08-23-2006, 04:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •