Results 1 to 4 of 4

What the fudge!!!!!!!!!!!!!

This is a discussion on What the fudge!!!!!!!!!!!!! within the LT1 forums, part of the Vehicle Specific category; Alright. I put a new (ebay) opti on yesterday with a new water pump. The last pump leaked and killed ...

  1. #1
    Member kensz28's Avatar
    Join Date
    Mar 2008
    Location
    Mississipi
    Posts
    181

    Red
    1979 MALIBU, SBC T56.

    What the fudge!!!!!!!!!!!!!

    Alright. I put a new (ebay) opti on yesterday with a new water pump. The last pump leaked and killed my old opti. I can work on my car with my eyes closed so the following story puzzles me. I have a 95 Roadmaster with a .030 over lt1, aluminum heads, SLP headers, intake yada yada. Car fired on the second crank and idled great. It still throws the SES light on and off and when I had it scanned it before all this it showed 34 mass/map, but for all intents and purposes runs fine. Pulls like a frieght train!!!! Drove it around and bled the air from the cooling system and put her to bed for the night. Well, this morning since it was 30 and snowing I started it up to let her warm and it idled like $HIT. Wouldn't rev and popped and blew dark gray smoke from the pipes and backfired like crazy. I let it idle and opened the hood and when I set my right hand on the intake boot and used my thumb to rev the engine I distinctly felt a mild shock everytime I touched the throttle body. WTF? O.K. I'm thinkin' bad coil connection or wire is loose. I check everything and all is tight. So I swapped out the entire coil and module since I have a spare. Still running like trash. AAAAAAAAAAUGHH!! O.K. It still idles fine but won't rev without popping and cracking. I had a spare IAC and put it on. Now it turns over but won't start. PERIOD. So on goes the old IAC, same thing. No start. I checked for fuel pressure and I hear the pump prime but it trickled out of the schrader valve not squirt like I had assumed. I need to put a fuel pressure guage on it but at this point I'm to effing pissed off. My friend bought an eBay opti and the car ran for like 40 seconds and died. I have used them too and had great reults. I have a used GM one here I could try and swap over the cap n rotor too. But I really don't want to go through all that again even though I can do the swap in under an hour. HELP PLEASE.

  2. #2
    Member kensz28's Avatar
    Join Date
    Mar 2008
    Location
    Mississipi
    Posts
    181

    Red
    1979 MALIBU, SBC T56.

    O.K. I know it's krimmas today and y'all are busy. So I'll update. I changed both coil n module sets. Nothing. 40psi of fuel at the rail and no spark. That Mother Truckin' eBay opti is toast. Well, looks like I'm doa for awhile. Maaaaaaan this sux.

  3. #3
    Member kensz28's Avatar
    Join Date
    Mar 2008
    Location
    Mississipi
    Posts
    181

    Red
    1979 MALIBU, SBC T56.

    Well, if anyone cares I changed my opti today. I had a spare off a 96 formula a friend had. I put on an eBay opti that I paid more than $59 for.. Anyway, his cap n rotor were toast it was crossfiring. His opti unit was still good. So, I put my cap n rotor on his base since my old one worked and his did too the only problem was mine had bearing failure. Well, it started right up and is running fine. DON'T BUY FROM SKIPWHITE ON EBAY. I'm sending it back.

  4. #4
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    As soon as I read your first sentence that had "ebay opti" in it, I knew right away what the problem was.

    Don't buy anything but GM opti's for reliability. I learned that a long time ago Sorry to hear about your troubles. We all learned the hard way at one time or another.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oh Fudge
    By Nhra Firebird in forum Almost Anything Goes
    Replies: 26
    Last Post: 12-28-2010, 06:04 AM
  2. FUDGE!!!! I got caught.
    By FSANE in forum Almost Anything Goes
    Replies: 64
    Last Post: 07-16-2009, 01:39 PM
  3. Lance Bass Packs Fudge
    By FuxOnTheFirstDate in forum Almost Anything Goes
    Replies: 26
    Last Post: 07-29-2006, 07:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •