Results 1 to 4 of 4

stupid light stupid question

This is a discussion on stupid light stupid question within the LT1 forums, part of the Vehicle Specific category; hi i have a 96 z28 with 87XXX miles in it. my stock clutch recently gave out and i replaced ...

  1. #1
    Junior Member TAallday's Avatar
    Join Date
    Oct 2008
    Location
    san jose, CA
    Posts
    56

    blackk
    1996 camaro z28

    stupid light stupid question

    hi i have a 96 z28 with 87XXX miles in it. my stock clutch recently gave out and i replaced it with a clutch from a local shop called superior clutch. ive driven 500 miles and it feels good. question should the complete clutch have pressure. on mine theres like less that an inch on top of the clutch that feels wobbly. like if i touch it its loose and as i keep going down you can feel the pressure.. also as i shift gears they seem to grind..they go in but just grind and arent that smooth.. and when i put it in reverse in grind worse but still go in whats the deal?

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Sounds like there could be air in the system.

  3. #3
    Junior Member TAallday's Avatar
    Join Date
    Oct 2008
    Location
    san jose, CA
    Posts
    56

    blackk
    1996 camaro z28

    so how do you fix that? will getting a short shifter fix it? im thinking about getting one for the LT1.. any good ones?

  4. #4
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    No, you have to bleed the air out of the system. It's an easy and cheap thing to try before you start throwing parts at it. If I remember correctly, LT1 systems dont have a bleeder screw though, so you have to depress the slave manually. It's been awhile, but there are some write ups on how exactly to do it online.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stupid SECURITY light on,2000 WS6
    By fbodyNATION in forum Firebird / WS6
    Replies: 15
    Last Post: 07-20-2012, 05:56 PM
  2. stupid question
    By cags07 in forum Camaro / SS
    Replies: 8
    Last Post: 07-22-2010, 08:32 PM
  3. Stupid HP question
    By 2fast2blegal in forum Firebird / WS6
    Replies: 10
    Last Post: 11-12-2007, 02:04 AM
  4. stupid stupid parents.... but hilarious none the less
    By derrinx in forum Multimedia Section
    Replies: 4
    Last Post: 05-15-2007, 01:39 PM
  5. Ok here's a stupid question for ls1.com
    By hotrodd in forum Almost Anything Goes
    Replies: 16
    Last Post: 09-18-2006, 10:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •