Results 1 to 8 of 8

stumbles at high rpm's

This is a discussion on stumbles at high rpm's within the LT1 forums, part of the Vehicle Specific category; its a 97 ta, 6 speed, and last night i noticed it stumble at the top of 3rd, so i ...

  1. #1
    Senior Member bandit95's Avatar
    Join Date
    Sep 2005
    Location
    Beaumont, Tx
    Age
    34
    Posts
    1,795

    Blue GMC Canyon
    trans ams gone now

    stumbles at high rpm's

    its a 97 ta, 6 speed, and last night i noticed it stumble at the top of 3rd, so i cleaned out my throttle body and it was full of gunk (just bought the car), well as i was driving around after that i noticed it stumbles around 5k rpm and up in at least 1st to 3rd (thats all i went through). any suggestions?

  2. #2
    Junior Member
    Join Date
    Dec 2005
    Location
    Arizona
    Posts
    36

    Green&Teal
    1993TA 1998Z28

    Lightbulb

    Could be fuel pump?

  3. #3
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Check your fuel pressure regardless, but I'd say an ignition issue.

  4. #4
    Junior Member
    Join Date
    Jun 2006
    Location
    Miami, Florida
    Age
    32
    Posts
    83

    green
    1996 z28

    hopefully not the problem, but thats what my opti was doing before it went out

  5. #5
    Senior Member bandit95's Avatar
    Join Date
    Sep 2005
    Location
    Beaumont, Tx
    Age
    34
    Posts
    1,795

    Blue GMC Canyon
    trans ams gone now

    Quote Originally Posted by 96lt1z28 View Post
    hopefully not the problem, but thats what my opti was doing before it went out
    thats exactly what i thought when it started acting up, i hope it's not that either. it has 102k miles and i just got it, dont know what all has been tuned up so i guess i'll just start gettin things as i go.

  6. #6
    Junior Member
    Join Date
    Oct 2005
    Location
    dallas
    Posts
    23

    red
    97slp ramair

    Opti

    IT does it about 5000 5300 its your opti Just get a new one...

  7. #7
    Junior Member
    Join Date
    Jun 2006
    Location
    Miami, Florida
    Age
    32
    Posts
    83

    green
    1996 z28

    that might be the reason they sold it, they might have known it was going out

  8. #8
    Fayhee Motorsports hotrod18_69's Avatar
    Join Date
    Nov 2005
    Location
    Kingman, AZ
    Age
    37
    Posts
    60

    Sebring Silver
    97 Camaro Z28

    I would say its the opti too.. I am having the same issuse.. I am on my 2nd new opti and its still doing the same dam thing.. All my other ignition parts are new.. Soo its Deltec time for me..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. car stumbles at first when cold?
    By seweber in forum General Help
    Replies: 34
    Last Post: 11-11-2012, 11:21 AM
  2. Finished upgrades.. car stumbles with throttle
    By ls1summy in forum General Help
    Replies: 4
    Last Post: 06-02-2010, 10:39 AM
  3. Engine stumbles at 2K rpm stops at 3K
    By bcorwin in forum General Help
    Replies: 22
    Last Post: 01-09-2010, 08:55 AM
  4. 99 ls1 stumbles on acceleration
    By 99blackLS1 in forum Firebird / WS6
    Replies: 1
    Last Post: 05-03-2007, 09:34 PM
  5. idles then stumbles and dies!!!
    By huggerz28 in forum LT1
    Replies: 1
    Last Post: 03-19-2007, 10:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •