Results 1 to 5 of 5

Some Wierd Stuff??

This is a discussion on Some Wierd Stuff?? within the LT1 forums, part of the Vehicle Specific category; Alright, I need help guys. I'm sort of stressed. The car in subject is a '93 Z28. I put up ...

  1. #1
    LTX N20LT4's Avatar
    Join Date
    May 2007
    Location
    Cali
    Posts
    2,006
    10's N/A

    Some Wierd Stuff??

    Alright, I need help guys. I'm sort of stressed. The car in subject is a '93 Z28. I put up a thread a while ago called "Lackluster LT1" because of an issue with power and driveability I was having. At the time, my Z would have lots of power on hand one day, and then very little the next. Driveablity was horrible because I was having to get on the gas a lot just to get up to cruising speed. Obviously Fuel mileage suffered as well. It was an ongoing thing for some time until about a month and a half ago, when out of nowhere, it started running fine again, and then stayed that way. Wierd.

    Yesterday, as i'm accelerating onto the freeway, I notice my Service Engine Soon light came on. It stayed on all the while I was on the freeway, and then as I decelerated off the freeway, it wen't off, to never come back on that day. Then, as if it couldn't get any wierder, today, it came on as I accelerated onto that same freeway, stayed on, and then wen't off as I decel'd. The car felt fine; nothing out of the ordinary. I ran a few eron's, then started on my way back home. After about 45 minutes of driving around town, my SES light came on; the first time it lit up in the city. It stayed on shortly and then wen't off again.

    As I was sitting at a stop light 3 miles from home, I noticed my car had some vibration going on - not to bad, but enough to notice. Remember at this time the SES light is OFF. Then, when I started to accelerated, the car started to lag like it didn't wan't to accelerate, while at the same time still vibrated slightly. It did this for only about 10 minutes.
    Now you guys are going to trip on this one. The car continued to hesitate and vibrate. When the SES light came back on, the car wen't back to NORMAL; the vibration and everything else was stopped. It's as if the SES light coming on made the problem stop. The SES light stayed on and the car ran perfect until I got home. What in the world could possibly be going on???

  2. #2
    Member
    Join Date
    Jul 2006
    Location
    oceanside ca
    Posts
    943

    Red
    06 GTO

    opti or fuel is my opinion, get a code reader and look at the code. if you have any kind of software, you can check codes that are going to be thrown.

  3. #3
    LTX N20LT4's Avatar
    Join Date
    May 2007
    Location
    Cali
    Posts
    2,006
    10's N/A

    Isn't there a way you can check the SES code with OBD-I cars without software? A procedure that gets the light to flash several times, giving you the code identification.

  4. #4
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    30
    Posts
    1,476

    Black
    94 Camaro Z28

    Just go to Autozone and have them check for free.

    As far as the problem stopping when the SES light comes on. I've heard that whenever it comes on, the car enters a 'limp home' mode and starts to run 'less aggressive' (can't think of the word I want, duh). It sounds like the opti though. Spark problems. But get those codes read.

  5. #5
    LTX N20LT4's Avatar
    Join Date
    May 2007
    Location
    Cali
    Posts
    2,006
    10's N/A

    Yeah, by now i'm thinking definitely opti. With 125k miles, I think it's about that time. Thanks for the info guys!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS: Z06 Rims, Suspension stuff, apperance stuff
    By uLs1a in forum Western Members
    Replies: 15
    Last Post: 01-06-2010, 11:12 AM
  2. Had a wierd dream and wierd day..
    By JoshieDoom in forum Almost Anything Goes
    Replies: 4
    Last Post: 08-27-2008, 07:30 AM
  3. More wierd stuff!!!!!!!!!
    By JoshieDoom in forum Almost Anything Goes
    Replies: 3
    Last Post: 03-21-2008, 03:46 PM
  4. Wierd Stuff Man
    By JoshieDoom in forum Almost Anything Goes
    Replies: 26
    Last Post: 03-20-2008, 11:58 AM
  5. Replies: 5
    Last Post: 09-10-2005, 12:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •