Page 1 of 3 123 LastLast
Results 1 to 20 of 43

Severe hesitation/jerking

This is a discussion on Severe hesitation/jerking within the LT1 forums, part of the Vehicle Specific category; My cars developed severe hesitation/jerking from 1500-2100rpm, worse when not warmed up yet. WTF? Everything was working fine, now the ...

  1. #1

    Severe hesitation/jerking

    My cars developed severe hesitation/jerking from 1500-2100rpm, worse when not warmed up yet.

    WTF?

    Everything was working fine, now the car sounds like its going to die only 300 miles after the installs. Belt is now squeeling like mad, and the car jerks like someones slamming on the AB brakes while going through the 1500-2100rpm zone, but runs fine above and idles fine. what the hell is it? its so bad it almost throws your head forward and backward like the power is being cut in half then comming on again. not as bad with more pedal but its getting worse, and it wasnt there before! this is a good 3 weeks after the installs have already been done, and everything was going fine breaking it in and all. no misfire data, no codes, o2's seem to be working albiet its running rich...

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    LA
    Age
    37
    Posts
    568

    Grey
    2010 Camaro 2SS/RS CGM

    Opti FTMFL

  3. #3

  4. #4
    Junior Member
    Join Date
    Jul 2006
    Location
    Newport KY
    Age
    32
    Posts
    80

    Red
    1995 Chevy Camaro

    Opti-spark took a

  5. #5
    Right On Badbird's Avatar
    Join Date
    Jan 2007
    Location
    SRB,Florida
    Age
    36
    Posts
    338

    Green
    1997 ws-6

    thats what i was thinking as welll

  6. #6
    M6 King Hot Black Trans-Am's Avatar
    Join Date
    Mar 2006
    Location
    WI
    Posts
    5,085
    Blog Entries
    1

    09 EclipseGT 75 Chevy 4x4
    2001 Trans-Am 13 F-XT

    How I don't miss that Opti!

  7. #7
    Junior Member
    Join Date
    Feb 2007
    Location
    Atlanta
    Posts
    41

    black
    94 z28

    it prob is the opti my water pump went bad and got it wet mine did the same shit , stuttered alot on bottom end new opti fixed it make sure the waterpump is sealed right that is what fucked mine up i think

  8. #8
    why would only such a specific rpm range be affected?

  9. #9
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    30
    Posts
    1,476

    Black
    94 Camaro Z28

    Mine did the same thing. At low RPM's, it misfired, but when I got on it, it was fine. Replace the opti. Or get an LS1 or an engine that doesn't rely on the opti. Its a good idea with terrible placement.

  10. #10
    But its not reporting any misfires?

  11. #11
    Junior Member
    Join Date
    Jul 2006
    Location
    Newport KY
    Age
    32
    Posts
    80

    Red
    1995 Chevy Camaro

    Or he could go Delteq. A Delteq will set you back about $600, but you will never have to worry about opti failure. The fastest LT1s ever built run delteq. www.delteq.com its an AMAZING product. MSD has a newer one out also, but there to new to have a solid track record IMO. Just something to think about.

  12. #12
    Ouch expensive

    How about the Accel systems? They are $250 and say they are better built then optis... considering this opti lasted 11+ years i'm not all to enthuzed about opening up another credit card for an all new ignition system

  13. #13
    Right On Badbird's Avatar
    Join Date
    Jan 2007
    Location
    SRB,Florida
    Age
    36
    Posts
    338

    Green
    1997 ws-6

    do you know how much a opti costs and how hard it is to replace? it is money well spent in IMO

  14. #14
    problem is i dont have the money, i'm already $2300 in debt with $17 in my checking.

    do i need a whole new opti or just the cap and rotor (found for $150 by msd)

  15. #15
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Keep in mind your coil and ignition module. I cant believe how many problems you're having after your parts installs. Something tells me it wasnt done with the utmost care...

  16. #16
    Junior Member
    Join Date
    Jul 2006
    Location
    Newport KY
    Age
    32
    Posts
    80

    Red
    1995 Chevy Camaro

    Id have to see what you have bro... I would guess a new opti. Dog leg it till Firday and buy one. dont buy used b cause u could get banged. Dont buy from the dealer cause u WILL get banged. Just my Dose centavos

  17. #17
    Member jasonisdn's Avatar
    Join Date
    Aug 2005
    Location
    nc
    Age
    42
    Posts
    294

    red
    96 ss

    http://shbox.com/1/4th_gen_tech2.html#Dal_and_Jason

    thats the 2 cheapest places to get a opti. just stick with the OEM opti.

  18. #18
    do i need the whole thing or just the $150 cap kit they sell... its not throwing any codes and upper rpms work fine, think the sensor itself is ok?

  19. #19
    Member jasonisdn's Avatar
    Join Date
    Aug 2005
    Location
    nc
    Age
    42
    Posts
    294

    red
    96 ss

    be safe, buy the entire thing. its money that will be well spent.

  20. #20
    Ok seriously WTF. Car was PERFECT today, no hesitation what so ever... all day. This morning, afternoon and even tonight...

    The only thing I did was let the car sit for 24 hours in my garage while I let the epoxy dry on the headlight motors which I installed those brass gears in..................

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GDP Q1 Severe Contraction... Here Comes the Double Dip....
    By wileyCoyote in forum Political / Debate Forum
    Replies: 1
    Last Post: 06-25-2014, 08:48 AM
  2. jerking
    By ls1wallen in forum Automatic Transmission
    Replies: 5
    Last Post: 09-20-2011, 08:31 AM
  3. close the sun roof when jerking off
    By 02Sweet in forum Almost Anything Goes
    Replies: 18
    Last Post: 05-08-2009, 09:29 PM
  4. Jerking/Shuddering still
    By freshduckie in forum General Help
    Replies: 18
    Last Post: 04-16-2006, 06:16 PM
  5. Tranny is going out! Severe whine above 45 mph!
    By Roastem in forum Manual Transmission
    Replies: 14
    Last Post: 01-13-2006, 09:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •