Results 1 to 4 of 4

Running rough if running at all help

This is a discussion on Running rough if running at all help within the LT1 forums, part of the Vehicle Specific category; I have 1994 z28 and its been running a little rough then the other day it starting running absolutely horibly ...

  1. #1

    Running rough if running at all help

    I have 1994 z28 and its been running a little rough then the other day it starting running absolutely horibly and I noticed that the security light was on could that be affecting the way it runs?

  2. #2
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    That usually wont allow it to start. Plugs wires O2's could be it. Do you have a check engine light? Have you had it scanned?

  3. #3
    No I dont think its been scanned i took it to a mechanic to have the car looked at because it wasnt starting but he was an idiot so i dont think its been scanned but the computer was re-flashed

  4. #4
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Quote Originally Posted by ichliebecamaro View Post
    No I dont think its been scanned i took it to a mechanic to have the car looked at because it wasnt starting but he was an idiot so i dont think its been scanned but the computer was re-flashed
    reflashed how? preformance tune, or codes cleared? If the starter wont engage it could be the key. They were out and sometimes it will work and other times it wont. If it isn't running right there is something else going on. Unless he cleared the codes you should be able to get them. Is it running right now?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Lq4 running rough
    By Ripper3494 in forum General Help
    Replies: 17
    Last Post: 10-25-2011, 04:01 AM
  2. Question: running rough
    By 90ARAPAJ in forum Firebird / WS6
    Replies: 3
    Last Post: 06-21-2011, 12:47 PM
  3. help- car's running rough
    By Ramairgod84 in forum General Help
    Replies: 2
    Last Post: 08-14-2010, 07:36 AM
  4. ls1 running rough
    By ls1_02 in forum General Help
    Replies: 0
    Last Post: 01-04-2008, 09:43 PM
  5. 94 Z28 running rough, any help?
    By 1st TA in forum LT1
    Replies: 4
    Last Post: 06-17-2007, 06:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •