Results 1 to 4 of 4

Problems... whats new.

This is a discussion on Problems... whats new. within the LT1 forums, part of the Vehicle Specific category; I'm leaking power stearing fluid like mad.. its spraying all over the engine bay and has to be filled 1ce ...

  1. #1

    Problems... whats new.

    I'm leaking power stearing fluid like mad.. its spraying all over the engine bay and has to be filled 1ce a week. Power stearing cuts out every once in awhile and whines like a bad supercharge only not nearly as cool sounding. Im just gunna buy one on ebay but I need to know what else I'll need for the garage in terms of gaskets, bolts ect other then PS fluid obviously. Are there any lines or cables I should also replace?

    problem 2: i get a low oil warning OR a low coolant warning every other time i start the car it seems. i'll start it monday and it says low oil. i start it tuesday oil lights not on, but low coolant comes on. wensday no lights. thursday oil light. etc. (not really per day but almost like that!) i check the oil and it always looks fine. coolant i have no idea where to check the level, anyone give me a hand? i found the fill port but thats it.

    problem 3: i put the block off plate back in my borla exhuast to make it quiet enough to pass inspection which is this month... but since i have, the idle has gone from around 900 to like 1500 and if i go into nuetral the rpm's stay high like 2000rpm until i come to a complete stop...wtf?


    ps. its a 1996 trans with 69k miles on it with a top end rebuild le2 all bolt ons and brand new msd opti less then 500 miles ago.

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    I would say buy the power steering pump locally so if there is a problem you can return it. I know on the older ones you needed a puller to install. I took one to a good parts store and I paid like 20 bucks. Check the lines for kinks or soft spots in the rubber. I have had the cooling light problem too. I had the sensor changed and it was good. I don't know where the oil one is. To check the coolant look near the battery for the overflow. There is a dipstick in the cap. The better way is open the radiator cap when the car is COLD. DONT DO IT WHEN HOT. THERE IS PRESSURE AND IT WILL BURN YOU. If it is full then I wouldn't worry about the light. The idle I am not sure about. I think the computer has to relearn the idle.

  3. #3
    would a leak from the power stearing also cause a loss of coolant and oil? or are these symptoms of something else gone horribly wrong.

  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    no, just unrelated things. If you are losing coolant and oil it could be a head gasket. Do you get any weird colored smoke from the exhaust? White is coolant, blue is oil.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Whats up Everyone
    By 2002z28camaro in forum New Member Introductions
    Replies: 2
    Last Post: 05-21-2008, 01:36 PM
  2. Fuel injector problems now... whats next?
    By grandkodiak in forum LT1
    Replies: 2
    Last Post: 01-10-2007, 03:35 PM
  3. Whats Up!
    By cocheesews6 in forum New Member Introductions
    Replies: 2
    Last Post: 01-10-2007, 03:22 AM
  4. Whats up
    By MeatL0af in forum New Member Introductions
    Replies: 37
    Last Post: 08-06-2006, 07:37 PM
  5. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •