Results 1 to 4 of 4

power steering probs

This is a discussion on power steering probs within the LT1 forums, part of the Vehicle Specific category; Hey i am 96 trans am, and i was driving it just fine and i had to turn around in ...

  1. #1
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    power steering probs

    Hey i am 96 trans am, and i was driving it just fine and i had to turn around in the road and it worked fine but after i got straight from turning around i have no power steering at all, its really hard to turn!! i got home and checked for leaks maybe a busted hose , but no bust, and all the power steering fluid is still filled up . What could be the Problem?????? Please Help!!!
    thanks

  2. #2
    Junior Member
    Join Date
    Aug 2005
    Location
    Tampa, FL
    Posts
    19

    silver
    1996 Trans Am

    I had the same problem and had to replace the PS pump.

  3. #3
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    well i just popped my hood and looked in the day light and whenever my car is off the belt is halway on the pulley and whenver i crank it and rev it up the pulley come outward like its going to come all the way off and the belt is about 1/4 of an inch on still and whenever i idle it back down, the pully goes back on but the belt is still halway on and not all the way on. So i dont have a clue what it is, never had this problem before, cause wheneveri rev up the pulley comes outward like its going to sling off or come off so maybe it is the ps pump.

  4. #4
    Junior Member
    Join Date
    Aug 2005
    Location
    Tampa, FL
    Posts
    19

    silver
    1996 Trans Am

    Sounds like there is an issue with the PS pump shaft, I would recommend replacing the pump. I think its around $60 for the pump, but it is a challenge working in tight places. I was able to change mine without removing any coolant hoses, I pulled the alternator and disconected the ps line from the rack to get the pump out, then I disconected the line from the pump once the pump was partially out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Power steering
    By 1998ss in forum Stereo and Electronics
    Replies: 1
    Last Post: 09-17-2013, 04:02 AM
  2. Question: Power Steering, Manual Rack, Power Steering Pumps-etc
    By TerribleTed in forum General Help
    Replies: 2
    Last Post: 11-18-2010, 05:37 PM
  3. power steering
    By 99ss in forum General Help
    Replies: 9
    Last Post: 05-29-2010, 01:57 PM
  4. Power Window Probs 02 CAMARO
    By blackcamarob4c in forum General Help
    Replies: 13
    Last Post: 06-03-2008, 07:04 AM
  5. power steering help
    By camarostripes96 in forum External Engine
    Replies: 5
    Last Post: 06-07-2007, 03:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •