Results 1 to 2 of 2

OTVC wire problem

This is a discussion on OTVC wire problem within the LT1 forums, part of the Vehicle Specific category; the spark ends for the distributor wont snap on and no matter how hard i push there are a couple ...

  1. #1
    Member
    Join Date
    Aug 2005
    Location
    LA
    Age
    37
    Posts
    568

    Grey
    2010 Camaro 2SS/RS CGM

    OTVC wire problem

    the spark ends for the distributor wont snap on and no matter how hard i push there are a couple of them that just wont go on, anyone have any ideas?

  2. #2
    Paid 2 Post Daycrew SexOnWheels's Avatar
    Join Date
    Jul 2005
    Location
    Canada
    Age
    38
    Posts
    9,485

    Blood Red
    Z28

    You are suppose to 'lube the shit out of them' to help get them to snap.

    'They' say the spray bomb white lithium grease is the best lube to use....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 03:50 PM
  2. How much wire ?
    By stew215 in forum Stereo and Electronics
    Replies: 27
    Last Post: 01-12-2010, 03:08 PM
  3. I-wire mod
    By CamaroFan71 in forum General Help
    Replies: 7
    Last Post: 03-19-2008, 10:06 PM
  4. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 08:51 AM
  5. Coil Pack Wire Harness Problem??
    By 20WS601 in forum General Help
    Replies: 6
    Last Post: 11-28-2007, 05:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •