Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 57

Opti Spark Problems

This is a discussion on Opti Spark Problems within the LT1 forums, part of the Vehicle Specific category; I never took my fans off, and no offence lee, but I recommend NOT buying a GM opti, most people ...

  1. #21
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    34
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    I never took my fans off, and no offence lee, but I recommend NOT buying a GM opti, most people recommend staying away. They are crap and are the reason everyone hates the opti design in the first place

  2. #22
    LT1KING GOODZ/BADZ's Avatar
    Join Date
    Nov 2005
    Location
    Fontana, Ca.
    Age
    37
    Posts
    127

    Black/Black
    96 Vert Z28-RIP/94 TT Z28

    My car seems to be doing the same crap. If i step on it from idle it just bogs and barely moves but if I ease into it and once it's above about 1500 rpm's it runs fine and doesn't miss through the rest of the rpm range. A couple of times it's even turned off on me as I came to a stop light. There's no SES codes either. Has anybody here used the Delteq coil near plug kit?

  3. #23
    lee1rbc
    Guest
    I agree the opti is an awful design, but unless you are going to convert to a coil pack system or some other type of igntion set up what's better then a new GM opti?

  4. #24
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    34
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    #1 choice, MSD now offers a whole unit rather than just the cap and rotor
    #2 the rebuilt units seem to last longer than GM

  5. #25
    lee1rbc
    Guest
    The MSD unit is sweet! but IMO you get what you pay for. I put a rebuild in my 95Z and it lasted 2 months, I then switched it out for a new OEM opti and no problems (at least for the final year I had the car) who knows today it could be on its fifth opti . Also after I learned about the opti prob I never went thru a car wash, ovoided driving in the rain and especially any puddles.

  6. #26
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    34
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    I went swimming in mine, two days later my rotor was independent from the opti, doesn't work too well that way. The main reason they go out right after an install is a leaking water pump from the reinstallation, it seems no one can get it back on an LT1 right. It doesn't leak enough to get to the ground, but enough to get the new opti to be a bitch. Also people don't replace the seal where the dist goes into the block, that ends up causing probs too.

  7. #27
    1BADLT1
    Guest
    Quote Originally Posted by z_driver1
    the ses light would be flashing

    It depends on the severity (sp) of the misfire.

  8. #28
    1BADLT1
    Guest
    I have to agree with lee, if you are replacing stock parts put AC Delco stuff back on the car. They know that car better than any other part company.

  9. #29
    Member dkishton1486's Avatar
    Join Date
    Nov 2005
    Location
    Ohio
    Age
    31
    Posts
    123

    Black
    1995 Z28

    Well I think im gettin an AC delco one (free) cant complain but also would another sign of the opti going be the car giving off smells?

  10. #30
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    34
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    hmmmm, don't think so, gasish?

  11. #31
    Member dkishton1486's Avatar
    Join Date
    Nov 2005
    Location
    Ohio
    Age
    31
    Posts
    123

    Black
    1995 Z28

    Yeah gas and like its hard to explain burning (Like when a new exhaust is put on that kind of burnign smell) Sorry its kinda hard to explain

  12. #32
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    34
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    i will admit at theis point, I am not sure. I am no good at diagnosis

  13. #33
    Member dkishton1486's Avatar
    Join Date
    Nov 2005
    Location
    Ohio
    Age
    31
    Posts
    123

    Black
    1995 Z28

    I mean I kinda get the gas smell because if the opti is failing then it wouldnt be throwing spark in all the cylinders and the gas would be unburt, correct?

  14. #34
    1BADLT1
    Guest
    Yes you would have an excess of Hydro carbons(unburnt gas) if you are running too rich it can cause hesitations and a smell.

  15. #35
    Member dkishton1486's Avatar
    Join Date
    Nov 2005
    Location
    Ohio
    Age
    31
    Posts
    123

    Black
    1995 Z28

    Well I got the opti today and also got 2 (1.75 Liters) of Vodka should help, gonna attempt to do this Sat, Also when I put the harmonic baancer back on what should I tourqe (sp) down to how many foot pounds?

  16. #36
    1BADLT1
    Guest
    Invest in a haynes manual

  17. #37
    lee1rbc
    Guest
    crankpulley bolts are 75ft.lb If I remember right that is for the three bolts that hold the pulley. Here are two links that miight help.
    http://www.bfranker.badz28.com/fbody/torquespecs.htm
    http://shbox.com/1/4th_gen_tech1.html

  18. #38
    HottubChampion
    Join Date
    Jan 2006
    Location
    San Antonio
    Age
    35
    Posts
    29

    Peuter
    2000 Z28

    The shitty thing about the optispark is the fact that its located under the water pump. Faulty pump+electricty=fuck up situation. A buddy of mine has replaced the one in his firehawk 2 times already. Just the nature of the beast.

  19. #39
    Member dkishton1486's Avatar
    Join Date
    Nov 2005
    Location
    Ohio
    Age
    31
    Posts
    123

    Black
    1995 Z28

    Question ive been getting told that I need to adjust the timing after I put this back in is this true or is this just a swap out like take the old one out then install the new one and your done?

  20. #40
    lee1rbc
    Guest
    Just a swap. It can only go on one way. Also to help not get the new opti wet during install, after you have taken off the W/P make sure to lower the jack and push down on the front end, this will get out a little more coolant, then jack the car back up a little and use a lot of towells to dry well.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. opti-spark
    By 024mula in forum LT1
    Replies: 7
    Last Post: 03-10-2011, 07:54 AM
  2. opti spark
    By camarostripes96 in forum LT1
    Replies: 7
    Last Post: 09-27-2007, 09:25 PM
  3. Opti Spark Oil Leak
    By walbum in forum External Engine
    Replies: 0
    Last Post: 03-28-2006, 11:28 AM
  4. Opti Spark maybe?
    By bandit95 in forum LT1
    Replies: 2
    Last Post: 09-19-2005, 04:40 PM
  5. Opti spark problems I think
    By lt1transamgt94 in forum LT1
    Replies: 2
    Last Post: 09-12-2005, 12:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •