Results 1 to 8 of 8

opti-spark

This is a discussion on opti-spark within the LT1 forums, part of the Vehicle Specific category; I know a lady how owns a '95 Trans Am, and she writes: Ive got problems with my distributor and ...

  1. #1
    024mula 024mula's Avatar
    Join Date
    Dec 2010
    Location
    Ohio
    Age
    57
    Posts
    680

    silver
    '02 Firebird Formula

    opti-spark

    I know a lady how owns a '95 Trans Am, and she writes:

    Ive got problems with my distributor and heard that in the 95's there was issues with the opti-spark. What should i do replace the opti-spark or is there some way to change to a different type of distributor? just wondering if i put an opti-sparj back in it if i'll have the same issue down the road. thanks for any help
    Last edited by 024mula; 01-26-2011 at 01:36 PM.

  2. #2
    Member krese's Avatar
    Join Date
    Feb 2008
    Location
    Brewerton, New York
    Age
    42
    Posts
    544

    silver
    1996 Trans AM WS6

    going to have issues with EVERYTHING at some point down the road! it's called owning an older car. just put the new AC delco opti in it and not worry for another ~70k miles...

    don't ever go cheap. just spend for the ac delco!

  3. #3
    Junior Member
    Join Date
    Oct 2010
    Location
    Iowa
    Posts
    11
    1996 Camaro

    Same as above...also there is a lady on Ebay that sells good optis. Or she did the last time I knew, just don't remember her name (optilady or something idk).

  4. #4
    Member krese's Avatar
    Join Date
    Feb 2008
    Location
    Brewerton, New York
    Age
    42
    Posts
    544

    silver
    1996 Trans AM WS6

    Quote Originally Posted by Black18Ice View Post
    Same as above...also there is a lady on Ebay that sells good optis. Or she did the last time I knew, just don't remember her name (optilady or something idk).
    she is not on there anymore

  5. #5
    Junior Member
    Join Date
    Jun 2007
    Location
    Ohio
    Posts
    14

    Green
    95' Trans Am

    What are the signs that your opti may be starting to go bad? Will it trigger a "Service Engine Soon" light? My light is on and stays solid but I've really noticed no performance or drivetrain losses??

  6. #6
    Member kensz28's Avatar
    Join Date
    Mar 2008
    Location
    Mississipi
    Posts
    181

    Red
    1979 MALIBU, SBC T56.

    When mine started failing the SES came on and off. It shifted late and hard. I actually got a code 34 for the MAF/MAP sensors. It didn't do it all the time. I lived in denial and checked the TPS the IAC all sorts of stuff. But alas, it was the opti. Usually the main portion lasts a long time, it's the cap and rotor that go bad. Mine got ate up where the rotor button sits and that's about it. The bearings also started to go out too. Get an Accel ($225) new or one from ChandlerMotorsports on eBay. I got a complete one for $89.00 for my friends 96 formula convertible A4. No problems at all. The one I got from skipwhite on eBay is a pile of SHIT. I went cheap and it cost me. Never go cheap on these!!!!!!!! I learned the hard way.

  7. #7
    Junior Member
    Join Date
    Mar 2011
    Location
    gardena, ca
    Posts
    21

    artic white
    1998 camaro z28

    guys to be honest i been down that road several times..the optispark is a big pile of bs! my first lt1 was a 1993 and that is a the worst year for the lt1! cause its not a vented/vacum and the egr lines are routed different! but i got it fixed and i ran real good! then i noticed that the water pump seals were leaking and water got in and screwed everything up! then i picked up a 95 lt1 and the same scenario hapend but to make maters worse i had to replace the seals and gaskets on the camshaft cover! due to oil was in the opti!
    but i will tell you this much wen it comes to optis i dont think its worth buying the big expensive fancy ones like msd or accel, they all do the same thing! take it from me i did countless opti swaps!

  8. #8
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Might get a stumble under load or it might not run well at all.

    My dad has an MSD in his 93. I think stockers are just fine, I have known of a few guys running 10s on the stocker.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. opti spark
    By camarostripes96 in forum LT1
    Replies: 7
    Last Post: 09-27-2007, 09:25 PM
  2. Opti spark question
    By Ratdaddy07 in forum General Help
    Replies: 4
    Last Post: 03-16-2007, 01:40 PM
  3. Opti Spark Oil Leak
    By walbum in forum External Engine
    Replies: 0
    Last Post: 03-28-2006, 11:28 AM
  4. Opti Spark Problems
    By dkishton1486 in forum LT1
    Replies: 56
    Last Post: 02-09-2006, 08:28 AM
  5. Opti Spark maybe?
    By bandit95 in forum LT1
    Replies: 2
    Last Post: 09-19-2005, 04:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •