Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Opti

This is a discussion on Opti within the LT1 forums, part of the Vehicle Specific category; Hi Guys, My car died a couple of days ago while I was driving it. Got it home, I checked ...

  1. #1
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    Opti

    Hi Guys,
    My car died a couple of days ago while I was driving it. Got it home, I checked fuel pressure and pressure was good. No spark. Changed out ignition module and coil, still no spark. I have a new AC Delco OPTI. What is involved in changing it? It is a 1993 LT1.
    Thanks,
    Todd

  2. #2
    Junior Member
    Join Date
    Nov 2010
    Location
    Madison Virgina
    Posts
    9

    Black
    1994 Z28 Camaro

    I have to put another optispark on my car. Not to bad to replace. Pull the crankpully and the waterpump and you can get right to it. You will need a small E4 Reverse Torks socket(i think thats the size. i have one at work and cant look at it now) to remove the cap. Other than that not to bad to replace.
    .

  3. #3
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    There are online tutorials with pictures that should help you out.

  4. #4
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Belts, pully, water pump, wires.....oh and the induction tube for the air box.

  5. #5
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    well got it all tore down, all cleaned up and the opti is different were there a change in this opti?

  6. #6
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Is it vented?

    They swapped over to them after a few years.

    What is differnet?

  7. #7
    autoconnectionllc.com 02transamce's Avatar
    Join Date
    Nov 2008
    Location
    Montgomery,Ala
    Posts
    2,436

    2007 Corvette
    Ebony

    If i'm not mistaken the 95-97 lt1s had a redesigned opti.
    Posted via Mobile Device

  8. #8
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    yes its vented, 93 lt1 so looks like a 95 opti. but there was no vent hose on it when i tore it down, i bought the car from a lady at work and she said she had lots of problems with this.

  9. #9
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    They did have a revision but I thought they would still work from year to year. Cant be 100% sure on that. I know my dads 93 has an MSD Opti.

  10. #10
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    the opti came off the car it has a shaft that has splinds on it and the new one didnt and the new cap doesnt have a vent but the old one did but didnt have nothing hooked up to it
    Last edited by juice nukem; 05-01-2011 at 08:05 PM.

  11. #11
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Huh, sounds like someone retro-fitted a later version and now you have a stocker to put on it.

  12. #12
    Member krese's Avatar
    Join Date
    Feb 2008
    Location
    Brewerton, New York
    Age
    42
    Posts
    544

    silver
    1996 Trans AM WS6

    Quote Originally Posted by TLS_Addict View Post
    Huh, sounds like someone retro-fitted a later version and now you have a stocker to put on it.
    ^^ THIS!


    a vented opti isn't going to do you a damn bit of good with out the vacuum lines and 93-94 didn't have em. in fact it would be worse to put on the vented opti with nothing hooked up because you have open spots where water/moisture can get in. i would put in the correct part for 93 and be done with it.

  13. #13
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Quote Originally Posted by krese View Post
    ^^ THIS!


    a vented opti isn't going to do you a damn bit of good with out the vacuum lines and 93-94 didn't have em. in fact it would be worse to put on the vented opti with nothing hooked up because you have open spots where water/moisture can get in. i would put in the correct part for 93 and be done with it.
    HE IS BACK FROM THE DEAD! lol

    I would go with the stocker and just be done with it. Lots of guys run 10s on a stock opti.

  14. #14
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    Good evening guys,
    Finally got the right opti AC Delco. Straight forward and easy to do. Changed all the ignition parts, still have no spark. Two days before it stopped running, I had a alarm and command start put in. If the ECM bad, would the car have no spark? My brother is going to scan it tomorrow, he thinks it is the command start.
    Thanks,
    Todd

  15. #15
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    Computer checks out, it is not the alarm or the command start. Now I guess I will test the OPTIC Harness. Has anyone had an issue with these harnesses?

  16. #16
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    I havent. Any codes at all?

    You said you are getting fuel but no spark right?

  17. #17
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    Yes getting fuel no spark, changed OPTI and coil and ignition module. Got to go back to work to get a test light. Will check harness. It is Driving me CRAZY.

  18. #18
    autoconnectionllc.com 02transamce's Avatar
    Join Date
    Nov 2008
    Location
    Montgomery,Ala
    Posts
    2,436

    2007 Corvette
    Ebony

    Opti problems are a bitch. Good luck,man.
    Posted via Mobile Device

  19. #19
    Junior Member
    Join Date
    Mar 2011
    Location
    canada
    Posts
    17
    1993 trans am

    Hey guys,
    waiting for my brother to get back from holidays. My scanner won't do OB1, my brothers does both. If the ignition coil/module is bad will it throw a code?

    Thanks,
    Todd

  20. #20
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    I cant be certain as I havent dealt much with OB1. My experience with a bad coil in my fathers 1993 Corvette threw ZERO codes. However, it did have some spark but at upper RPMs it would go to shit.

    Does the car do anything when you turn the key?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need an opti
    By vflo85 in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 11-30-2012, 05:24 PM
  2. msd opti prob help please
    By dirttrax in forum LT1
    Replies: 10
    Last Post: 06-30-2012, 11:17 PM
  3. Is my Opti bad again?
    By LT4Hawk9 in forum LT1
    Replies: 14
    Last Post: 04-13-2011, 06:49 PM
  4. Help: Opti set up
    By 2000dreambird in forum LT1
    Replies: 9
    Last Post: 03-31-2010, 05:42 PM
  5. opti spark
    By camarostripes96 in forum LT1
    Replies: 7
    Last Post: 09-27-2007, 09:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •