Results 1 to 15 of 15

Is my Opti bad again?

This is a discussion on Is my Opti bad again? within the LT1 forums, part of the Vehicle Specific category; I know, I know...YES. '97 LT1 in a non-stock application. LT4 Hot Cam, LT4KM, and deleted rear O2 sensors. Otherwise ...

  1. #1
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    Is my Opti bad again?

    I know, I know...YES.

    '97 LT1 in a non-stock application. LT4 Hot Cam, LT4KM, and deleted rear O2 sensors. Otherwise pretty much stock. Recently started misfiring and then chucking big fireballs out both pipes (true duals without any kind of crossover...making it a misfire on both banks for certain). Sometimes it misfires for a few seconds then runs okay, sometimes it nearly cuts off...or does if I'm moving slowly...before coming back to life. Sometimes it lasts for just a few miles before acting up, sometimes 40 or 50 miles.
    With the fireball situation happening, I assumed it was ignition related, because to me that indicates that fuel is getting into the cylinders in excess, then when the ignition returns it lights off all of it resulting in the fireballs. I replaced the ICM since my old one was cracked...figured I may get lucky. Nope. Then I figured the coil is a heckuvalot cheaper than an Opti, so I replaced it. Went from barely idling when I put it in the shop, to running GREAT with the new coil. Then 40 miles later it went to crapola again. Tonight I washed it and now it won't start. No spark. So, I'm pretty well figuring it's the Opti, but it is a new Accel unit with about 60k miles on it, and I really don't wanna believe that it is the problem. I scanned it for codes before I put the coil on, and nada. That was just a few days ago, but will scan it again tomorrow just for giggles.
    So, I guess, help me diagnose it. Does the PCM shut down spark if fuel pressure drops?...or since I have no spark does that necessarily mean it IS ignition related?

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Sounds like the opti. Fuel pressure is easy to check with a gauge that you can rent if you want to eliminate that first.

  3. #3
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    Thank you. I am stuck in the Opti Denial stage right now. I'll accept it sooner of later.

    I have a gauge in my truck to take to the shop today and check it. I just didn't have it there last night. But still, is there any reason for the PCM to tell the ignition to NOT fire?...or am I pretty much looking at an ignition problem?

    I wanna check fuel pressure this morning, then pull the opti harness out to lay eyes on it, then I guess I'll oprder an MSD opti. I was supposed to be heading to the Charlotte Auto Fair tomorrow in it.

  4. #4
    Member krese's Avatar
    Join Date
    Feb 2008
    Location
    Brewerton, New York
    Age
    42
    Posts
    544

    silver
    1996 Trans AM WS6

    Quote Originally Posted by LT4Hawk9 View Post
    Thank you. I am stuck in the Opti Denial stage right now. I'll accept it sooner of later.

    I have a gauge in my truck to take to the shop today and check it. I just didn't have it there last night. But still, is there any reason for the PCM to tell the ignition to NOT fire?...or am I pretty much looking at an ignition problem?

    I wanna check fuel pressure this morning, then pull the opti harness out to lay eyes on it, then I guess I'll oprder an MSD opti. I was supposed to be heading to the Charlotte Auto Fair tomorrow in it.
    just get the AC Delco, don't waste your $ and time on the MSD because it really isn't any better....... just my .02

  5. #5
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    Quote Originally Posted by krese View Post
    just get the AC Delco, don't waste your $ and time on the MSD because it really isn't any better....... just my .02

    Find me a GM one for a deal, and I'm game for whatever. I do like the MSD's "extra bolts" to help seal it anyway, but less money will make me go for the GM one. No big deal to me either way, really.

    The best price on a GM one that I have found is Summit, and it's $392.90 shipped/ This MSD is $416.87 shipped...worth the extra $25 to me for the MSD. LINK

  6. #6
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    You might also want to check the harnesses that go to the opti.

  7. #7
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    I pulled the harness, and it looked like new. Contacts and seals were all good. I didn't check it with an ohmmeter, but it looked good.

  8. #8
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    New MSD (which eliminates the opti cable, BTW), new Autozone coil and ICM. Same symptoms.

    NEXT?

  9. #9
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Getting fuel?

  10. #10
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    Yessir. You can let it idle for a good while, long enough that the fans come on, then cycle a time or two, then it's like you flipped a switch and it starts to run rough, idle speed drops to too low and rough to maintain idle, and it dies. Fires right back up and idles fine again until it suddenly starts to run rough again.

    Going down the road it is fine, then suddenly runs like crapola. Seems to be electrical, thus my replacing most of the ignition parts. Am I chasing a fuel problem in the electrical system?

  11. #11
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    When I had issues with my LT1 I replaced a lot of stuff. Mine would run great then like crap and then it even shut off a few times but it would start right back up and run fine and then like shit.

    I put some seafoam in the gas, changed the fuel filter, air filter (cut lid as well), plugs, wires, opti-spark, and the water pump. I even had the garage check the ohms and what not on the injectors to make sure everything was within spec. After that it ran like a raped ape!

  12. #12
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    Well, I'm well on my way to replacing all that. The expensive stuff is down.

    I've got a setr of Taylor wires, but I can't get the crimps to stay put on the friggin things. Maybe I'll get a set from Summit, premade. Plugs and fuel filter might get done tonight.

  13. #13
    Member
    Join Date
    Apr 2006
    Location
    Bridgewater, VA
    Age
    40
    Posts
    134

    Black
    1997 Firehawk LT4

    I put a fuel filter on it, still not right. I'm just running around the couple acre lot here, and afraid to hit the road with it too much for fear of having to drag it home. It seems to run okay at half-or-more throttle, but misses and carries on at low throttle position. There is a misfire code in it, but nothing else.

  14. #14
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Check for vacuum leaks. Does it show which cyl has the mis?

  15. #15
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Just take it to a good GM tech, pay the 100$ diag, and save yourself alot of time and money. A good tech, with a tech2 scanner and good electrical testing equipment can track this down.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need an opti
    By vflo85 in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 11-30-2012, 05:24 PM
  2. msd opti prob help please
    By dirttrax in forum LT1
    Replies: 10
    Last Post: 06-30-2012, 11:17 PM
  3. Opti
    By juice nukem in forum LT1
    Replies: 23
    Last Post: 05-16-2011, 12:10 PM
  4. Help: Opti set up
    By 2000dreambird in forum LT1
    Replies: 9
    Last Post: 03-31-2010, 05:42 PM
  5. opti spark
    By camarostripes96 in forum LT1
    Replies: 7
    Last Post: 09-27-2007, 09:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •