Results 1 to 7 of 7

Maf

This is a discussion on Maf within the LT1 forums, part of the Vehicle Specific category; If your maf is not working will it affect the performance of the vehicle. If so what are the problems ...

  1. #1
    Junior Member
    Join Date
    Dec 2007
    Location
    Alvarado TX.
    Age
    38
    Posts
    69

    white
    96 TransAM/ 05 Expedition

    Maf

    If your maf is not working will it affect the performance of the vehicle. If so what are the problems it will cause.

  2. #2
    Member brianswimmer23's Avatar
    Join Date
    Feb 2008
    Location
    stockton, California
    Posts
    127

    white
    97 z28/SS

    well it could cause idle issues and even stumble to name some! just get it cleaned they sell cleanera t all local autostores. if that doesnt help get it checked! what exactely are your problems?

  3. #3
    LT1KING GOODZ/BADZ's Avatar
    Join Date
    Nov 2005
    Location
    Fontana, Ca.
    Age
    37
    Posts
    127

    Black/Black
    96 Vert Z28-RIP/94 TT Z28

    Loss of horsepower, bad fuel economy, stumbling, rough idle, some major ones you'll notice.

  4. #4
    Member Zedicous's Avatar
    Join Date
    Feb 2008
    Location
    Slidell, LA.
    Age
    48
    Posts
    397

    Mystic Magentic Red
    99 C5, 98 Z28.

    Your car should be throwing a cel code, see what it says.

  5. #5
    Junior Member
    Join Date
    Dec 2007
    Location
    Alvarado TX.
    Age
    38
    Posts
    69

    white
    96 TransAM/ 05 Expedition

    Quote Originally Posted by brianswimmer23 View Post
    well it could cause idle issues and even stumble to name some! just get it cleaned they sell cleanera t all local autostores. if that doesnt help get it checked! what exactely are your problems?
    It starts missing really bad at higher rpm, also if tring to powerbrake it will just fall on its nose. But after about 1000 rpm up to about 4500 it runs just fine.

  6. #6

  7. #7
    Member FUELS94's Avatar
    Join Date
    Oct 2005
    Location
    Cheney Wa.
    Posts
    154

    red
    1996

    When my MAF went south the check engine light came on and my fans were also on all the time.
    1996 Z28 LT-1 (with basic bolt-on)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •