Page 6 of 6 FirstFirst ... 23456
Results 101 to 109 of 109

Lt1 Getting hot

This is a discussion on Lt1 Getting hot within the LT1 forums, part of the Vehicle Specific category; yea thats true should have thought about that im going to get a gasket kit and see if it works ...

  1. #101
    Junior Member b1z311's Avatar
    Join Date
    Jan 2010
    Location
    hawaii
    Age
    30
    Posts
    15

    black
    1996 firebird formula

    yea thats true should have thought about that im going to get a gasket kit and see if it works trial and error i guess for now i will keep everyone updated as i get the chance to replace things

  2. #102
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Is the airdam under the car still there?

  3. #103
    Junior Member b1z311's Avatar
    Join Date
    Jan 2010
    Location
    hawaii
    Age
    30
    Posts
    15

    black
    1996 firebird formula

    thanks i didnt even think about that

  4. #104
    Junior Member b1z311's Avatar
    Join Date
    Jan 2010
    Location
    hawaii
    Age
    30
    Posts
    15

    black
    1996 firebird formula

    ok if anyone is still tracking this i replaced the thermostat and the paper gasket and i watched the temp drop but it still over heats and there is alot of air in the line when i bleed it all out i drive it and it gets hot and i bleed it again and theres more air in the line where is it coming from open to suggestions

  5. #105
    Junior Member
    Join Date
    Oct 2009
    Location
    TX
    Posts
    1
    Glad to hear the op fixed his problem. I was gonna say since he changed his water pump, to pull the pump back off and recheck to see if the drive bit or whatever its called was installed. The water pump is driven by that bit. Maybe this will help someone else in the future. I had this problem before.

  6. #106
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Next I guess would be a pressure check of the system. They make a tool that you pressurize the system and you can listen for leaks. Could have a loose hose or a pin hole where it is getting air in.

  7. #107
    Junior Member b1z311's Avatar
    Join Date
    Jan 2010
    Location
    hawaii
    Age
    30
    Posts
    15

    black
    1996 firebird formula

    hey big ron i know you been throughing ideas at me left and right and i thank you very much but you wouldnt believe what was causing the problem it was a $17 relay switch for the fan speed control and now shes purrin like a kitten staying at 180 or below driving and 210 give or take at an idle thanks for everyones help

  8. #108
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Great to hear you finally fixed it.

  9. #109
    Junior Member
    Join Date
    Aug 2007
    Location
    Fontana, Ca
    Posts
    1
    Quote Originally Posted by b1z311 View Post
    hey big ron i know you been throughing ideas at me left and right and i thank you very much but you wouldnt believe what was causing the problem it was a $17 relay switch for the fan speed control and now shes purrin like a kitten staying at 180 or below driving and 210 give or take at an idle thanks for everyones help
    What part was it, because I am having the same issues was it this part http://www.autozone.com/autozone/cat...&parentId=63-0

Page 6 of 6 FirstFirst ... 23456

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •