Results 1 to 15 of 15

lt1 acting weird (video)

This is a discussion on lt1 acting weird (video) within the LT1 forums, part of the Vehicle Specific category; So lately my car has been acting weird, when I hit the gas it stumbles really bad and takes a ...

  1. #1
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    lt1 acting weird (video)

    So lately my car has been acting weird, when I hit the gas it stumbles really bad and takes a second then starts revving right. It used to be only under load it would lightly stumble and occasionally it woud run perfect. But one day I looked at my intake elbow and the rubber on the bottom had big cracks so I taped it for now and put it on good but now its doing this since i taped it...So on the video, the best example is at the 0:12 mark, i was holding the gas.. Sorry for the bad quality you kinda have to turn it up. [ame]http://www.youtube.com/watch?v=6VdoGQJFG88[/ame]
    Last edited by Mike510; 03-21-2011 at 09:15 PM.

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    throwing any codes at any point?

    Take a good long look at the entire intake and inspect for leaks. You should replace the intake elbow and check the MAF for any damage. Beyond that you're looking at a fuel or ignition problem and should scan it to gather further data.

  3. #3
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    Its not throwing any codes, Ive looked at the MAF and I don't know what to look for damage wise. I seem to remember my dad trying to clean them with a q-tip and I heard your only supposed to use special spray but im not sure. Also the MAF was put on the wrong way at one point if that would do anything to the contacts or whatever?

  4. #4
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    But thanks for the reply 5.0. But yea another thing I noticed it has a really strong gas smell when it runs, could that be opti not putting out spark to burn it enough D: . The car just hit 90k.

  5. #5
    Senior Member REVNORR82's Avatar
    Join Date
    Aug 2010
    Location
    NEW ALBANY
    Posts
    1,462

    silver
    2002 ws6 ta convertible

    Its the opti spark my cousins 96 z28 was doing the same thing got the msd pro billet opti spark been on their for a year now no problems and a noticeable change in the way the car performs.

  6. #6
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    Dang I was hoping it wasn't the opti . Well now the car won't even start. Im going to try to buy the intake elbow and try different things. thanks again for the replys.

  7. #7
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    Ok so now when I turn the key not to start turning it but just in the on position, the check gages and SES light stay on....but did they always do that until the motor starts? Or is it finally throwing a code?

  8. #8
    Senior Member REVNORR82's Avatar
    Join Date
    Aug 2010
    Location
    NEW ALBANY
    Posts
    1,462

    silver
    2002 ws6 ta convertible

    It does that

    Sent from my DROIDX using Tapatalk
    2002 WS6 TA VERT M6 HOOKER SUPER COMPS ORY AND CAT BACK TUNE DONE BY CHARLES AT GREAD TUNNING!!

    2007 Z71 EXTENDED CAB PROGRAMMER COLD AIR
    TRUE DUALS

  9. #9
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Well, if you smell fuel it may have been flooded, or flooding itself. It could very well be ignition at this point. If you can, use a code reader to see if it has any codes stored.

  10. #10
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    Dang I thought so, just wasnt 100% on those lights. Well this sucks...Does anyone know the absolutely cheapest way to fix the opti?

  11. #11
    Senior Member REVNORR82's Avatar
    Join Date
    Aug 2010
    Location
    NEW ALBANY
    Posts
    1,462

    silver
    2002 ws6 ta convertible

    Replace it!!!!

    Sent from my DROIDX using Tapatalk

  12. #12
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Get a decent priced opti if you can. My dad has an MSD and I went with a cheaper one and mine worked just dandy. Now, make sure you check your coil as well and while you are at it swap out your plugs and wires if need be.

    If you have a strong fuel smell I wouldnt say its a fuel problem. Do you know when/if the fuel filter was ever replaced?

  13. #13
    Stang Smoker
    Join Date
    Feb 2008
    Location
    alameda, CA
    Age
    27
    Posts
    60

    red
    1994 z28

    Well I have the stock filter back in and its fairly new, before all these problems I had on a ebay intake, just a tube with a filter. I definatly should check the coil too, I just have to go get a meter.

  14. #14
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am

    do you still have cats on it??? cats could be clogged... like others have said the opti junk could be crapping out... check the opti for anti freeze getting on it...

  15. #15
    Giant Dicks Car Club Zapper2003's Avatar
    Join Date
    Nov 2006
    Location
    Millerton, PA
    Posts
    5,144

    2005 Ram
    1978 Firebird

    Get a good quality code reader. Ours (the 150$ one from autozone) has a function that allows you to read the outputs of all the sensors. I fought with a similar stumble/rich condition for a year and a half. It ended up being a rusty connector at the coolant temp probe on the water pump. The motor would start up fine, then almost immediately go to running like shit, if I shut it off, it would not restart without holding the throttle to th floor. The rusty connector wasnt making any contact, and the PCM default is -40*F, causing the PCM to flood the motor with fuel. I replaced the opti, plugs, wires, tested every sensor, changed some other shit, and got no results. Once I found that my computer was thinking the motor was 40 below, I changed out the plug on the coolant temp sensor (you can buy these at autozone new), and I was in the clear. At the very least, if you don't have a scanner or access to one, just go pull off your intake, and check the plug on that sensor. The sensor is threaded into the face of the water pump and is somewhat easy to get at. Pull the intake ducting off, and its Just one clip and it'll pop right off, only two wires. Mine was visibly rusty. If you have any doubts, just get some good butt-connectors (the kind with weather-tight heatshrink on them) and replace the pigtail.

    I would shoot for getting a scanner and trying that first, though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: weird acting turn signal
    By johnny 5 in forum General Help
    Replies: 1
    Last Post: 02-19-2011, 08:29 AM
  2. Help Car is acting weird...
    By MRM 01 in forum Firebird / WS6
    Replies: 6
    Last Post: 04-15-2010, 03:04 PM
  3. Help: Windows are acting weird!!
    By JoshuaGrooms83 in forum Stereo and Electronics
    Replies: 5
    Last Post: 06-19-2008, 10:40 AM
  4. Oil needle acting weird.
    By Zeroskater1028 in forum General Help
    Replies: 3
    Last Post: 11-29-2005, 03:57 PM
  5. blinker switch acting weird
    By myk02k in forum General Help
    Replies: 3
    Last Post: 10-15-2005, 10:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •