Results 1 to 10 of 10

low coolant light

This is a discussion on low coolant light within the LT1 forums, part of the Vehicle Specific category; my low coolant light keeps coming on when there is plenty of coolant. whats the fix?...

  1. #1
    Junior Member
    Join Date
    Feb 2007
    Location
    dfw, texas
    Posts
    13

    silver, black
    01 vette, 95 t/a

    low coolant light

    my low coolant light keeps coming on when there is plenty of coolant. whats the fix?

  2. #2
    Formy4Ever Red4Mula's Avatar
    Join Date
    Nov 2006
    Location
    San Angelo, Tx
    Age
    30
    Posts
    224

    Red
    1995 Pontiac Formula

    Quote Originally Posted by divinezx9 View Post
    my low coolant light keeps coming on when there is plenty of coolant. whats the fix?
    I get that light on periodically also.. If you have full coolant, then most likely it's the sensor that's faulty, or a bad connection to the sensor..
    1995 Formula M6- Red... Throttle body airfoil, K & N FIPK2, TB bypass

  3. #3
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    The low coolant sensors are common problems. I believe the sensor is right below the filler neck on the radiator. Just drain some coolant out of the radiator and replace the sensor.

  4. #4
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    Correct, I Have Had 3 Forth Gens, And All Have Required A New Sensor

  5. #5
    Junior Member
    Join Date
    Jul 2006
    Location
    Newport KY
    Age
    32
    Posts
    80

    Red
    1995 Chevy Camaro

    You dont even have to replace it man. It gets coroded (i cant spell but u know what i mean). Carefully clean the tip of the sensor with a wire brush and re-install. 99% sure it will fix it. If not, its a bad sensor all together.

  6. #6
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    Good Info. Thanks For Teh Tip Man.

  7. #7
    Mine stays on and the levels fine... i just ignore it.

    the temp guage is the only thing i care about

  8. #8
    Junior Member red83's Avatar
    Join Date
    Dec 2006
    Location
    north ga
    Posts
    11
    yep, common problem

  9. #9
    Member Chad97z's Avatar
    Join Date
    Aug 2005
    Location
    Dallas / Irving
    Posts
    396
    I replaced mine once on my camaro, but Its still worth it to have. I'd rather replace it once in 140k miles than not have it. GM removed it form the LS1's. Oh well, I can fix my car though. Most people don't tinker.

  10. #10
    Member gd1996's Avatar
    Join Date
    Jul 2006
    Location
    Latrobe, PA
    Posts
    864
    I believe theyh can be unplugged if I read correctly and the light will go out, mines the same way, 5th lt1 car I had, first one with this problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low Coolant Light
    By BWA2110 in forum External Engine
    Replies: 3
    Last Post: 05-03-2009, 05:27 PM
  2. Cant get the low coolant light to go off
    By Redirwol1 in forum Computer & Tuning
    Replies: 31
    Last Post: 07-28-2008, 08:02 PM
  3. Low coolant light
    By wicked1 in forum General Help
    Replies: 2
    Last Post: 04-02-2007, 10:11 AM
  4. Coolant light...coolant level full.
    By SR71 in forum General Help
    Replies: 4
    Last Post: 01-08-2007, 10:35 AM
  5. coolant light on, full on coolant
    By Brownboy2020 in forum Firebird / WS6
    Replies: 10
    Last Post: 08-10-2006, 01:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •