Results 1 to 7 of 7

Just finished a rebuild!

This is a discussion on Just finished a rebuild! within the LT1 forums, part of the Vehicle Specific category; I just got my motor rebuilt due to fried piston rings. Now I've been driving it for 5 days, I ...

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Location
    edmonton, alberta
    Posts
    10

    black
    1995 trans am

    Just finished a rebuild!

    I just got my motor rebuilt due to fried piston rings. Now I've been driving it for 5 days, I put on 200kms and now I got a oil leak. I've also noticed that the oil pressure guage dont move so its got me worried! I was told that most likely it's the oil pressure sending unit! Doe's anyone have any suggestions?

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Try to hook up a mechanical pressure gauge in the engine compartment, just to make sure you do have pressure. If so, replace your sending unit. As for the oil leak, find it and replace the gasket

  3. #3
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Sometimes the opsu needs some teflon tape.

  4. #4
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Yea mine leaked after replacing it and I put teflon tape on it. just afraid I was going to break that damn small thread off in there.

  5. #5
    Junior Member
    Join Date
    Jul 2009
    Location
    edmonton, alberta
    Posts
    10

    black
    1995 trans am

    so i replaced the opsu and yep, that was the problem! But what a pain in the arse to remove it!

  6. #6
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Where is the opsu on lt-1's? I thought they weren't in the back like the ls-1's.

  7. #7
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    They are in the back behind the intake and at the top of the block deck same place since birth of the small block chevy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally finished it up!
    By silverWS6 in forum External Engine
    Replies: 7
    Last Post: 06-07-2010, 12:11 PM
  2. C6 ZR1 pics finished
    By nitrox28 in forum Almost Anything Goes
    Replies: 18
    Last Post: 05-26-2009, 01:38 PM
  3. Replies: 15
    Last Post: 08-06-2007, 05:59 PM
  4. Finished my LT1!! Take A Look!
    By silent101 in forum Camaro / SS
    Replies: 14
    Last Post: 01-03-2007, 07:37 PM
  5. car is almost finished
    By Nhra Firebird in forum Almost Anything Goes
    Replies: 5
    Last Post: 05-16-2006, 02:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •