Results 1 to 7 of 7

installing lt1 over the top

This is a discussion on installing lt1 over the top within the LT1 forums, part of the Vehicle Specific category; Just got my 383 back finally. I was wondering if anyone installed there motor through the top and how they ...

  1. #1
    Member
    Join Date
    Feb 2008
    Location
    york pa
    Posts
    125

    white
    96 ws6

    installing lt1 over the top

    Just got my 383 back finally. I was wondering if anyone installed there motor through the top and how they did it and what problems they ran into? Should I leave the auto trans in and on its mount? Any info on the install will b helpful.

  2. #2
    Dealing Powder ntimid8r7's Avatar
    Join Date
    Sep 2008
    Location
    Saint Cloud,FL
    Age
    39
    Posts
    194

    1994 Z28 MQBM
    2001 SS #1629 LPM

    you will be better off to do it from the bottom. If you do it from the top I would suggest taking most of the front off as you can. That will give you the room to get back far enough to drop it in. Leave the trans in the car and hook everything back up once the motor is in. BUT like I said, if you have the capability to do so, go from the bottom.

  3. #3
    Member
    Join Date
    Feb 2008
    Location
    york pa
    Posts
    125

    white
    96 ws6

    Thanks but me and my buddy already put it in through the top. It was easier than we thought. We had it in and on the mounts in about a hour.

  4. #4
    Dealing Powder ntimid8r7's Avatar
    Join Date
    Sep 2008
    Location
    Saint Cloud,FL
    Age
    39
    Posts
    194

    1994 Z28 MQBM
    2001 SS #1629 LPM

    good deal! I took mine from the bottom and if we hadn't drank so much beer we would have had it out in about an hour or so. How is it running?

  5. #5
    Member
    Join Date
    Feb 2008
    Location
    york pa
    Posts
    125

    white
    96 ws6

    I still need to hook the headers up and wrap up soom odds and ends. A also need a alt. Bracket and a computer tune. Ill let u know

  6. #6
    Member
    Join Date
    Feb 2008
    Location
    york pa
    Posts
    125

    white
    96 ws6

    Motor is in and installed all I need now is a alt. Bracket and a comp tune and I can fire it up. Can't wait

  7. #7
    Member Nightmare00's Avatar
    Join Date
    May 2007
    Location
    usa
    Posts
    119

    Black
    2000 WS6 Trans Am

    I did mine from the topside no problems!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installing a Cam?
    By Justin23454 in forum Internal Engine
    Replies: 14
    Last Post: 07-01-2010, 10:31 AM
  2. installing lt1 over the top
    By fastlt196 in forum LT1
    Replies: 0
    Last Post: 03-16-2009, 08:37 PM
  3. about to do my first mod.... installing an slp lid
    By derrinx in forum External Engine
    Replies: 23
    Last Post: 08-08-2007, 04:13 PM
  4. installing a cam
    By timd13 in forum General Help
    Replies: 2
    Last Post: 09-10-2006, 04:45 PM
  5. Installing TCS ??
    By Necction in forum General Help
    Replies: 11
    Last Post: 02-09-2006, 09:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •