Results 1 to 11 of 11

injectors

This is a discussion on injectors within the LT1 forums, part of the Vehicle Specific category; What power the injectors on lt1 no power...

  1. #1
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    injectors

    What power the injectors on lt1 no power

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    I thought you had this fixed with a new PCM? I'm convinced this is either a PCM issue or a VATS issue

  3. #3
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    Well it started again does the opti fire the injectors cause that's the only thing I haven't. Changed because I can start it up shuts right off

  4. #4
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Still sounds like a VATS issue

  5. #5
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    please help

    Ok guy well about three months ago my car started to back fire and the shut off so I thought it was the icm so changed it with a new coil so still nothing just turns over and over so I got a new computer with vats off so I got power to everything but the injectors are not spraying so I think the opti is bad but will fire with starter fluid. Please help

  6. #6
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Ok well I really don't know at this point specifically what you've checked. Read this thread for things you need to go through specifically.

    no injector pulse on LT1 please help! - LS1TECH

    I also think there's a chance this is a wiring issue, or still a VATS issue if it wasn't disabled correctly, if at all. And if the car starts and runs with starting fluid, I'm not sure why you think its the opti. If you're so anxious to throw an opti at it, go ahead.

  7. #7
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    Because it starting back firing it starts when it wants too I have a new computer icm coil my opti shows moisture a little never gave problem before

  8. #8
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    Well 5.0this it look to have done the trick cause she fire up on every turn but haven't test drove yet but she is alive so I will c tomorrow guys

  9. #9
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Well that's the first you mentioned of a misfire. And what exactly did you do to the car? The opti doesn't fire the injectors.

  10. #10
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    I had a mechanic tell me that it was no power to the computer so I got brand new one then it would just turn over and over I got spark and fuel coming through the rail just not get to the plugs so he did get the injectors firing it starting Turing over like was out of time.

  11. #11
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Ok I'm having a hard time understanding what you're saying.

    No power to the PCM...ok
    It would turn over, you had spark, and fuel at the rails.. what wouldn't get to the plugs (spark plugs?)?

    Then he had to do something to fix the injectors to get them to fire?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. F.A.S.T. Injectors??
    By ThunderChicken in forum Internal Engine
    Replies: 7
    Last Post: 05-31-2011, 10:31 AM
  2. Injectors
    By duweller in forum External Engine
    Replies: 9
    Last Post: 06-22-2010, 07:27 PM
  3. 42 lb injectors yes or no
    By fast93ta in forum LT1
    Replies: 19
    Last Post: 02-04-2008, 11:27 AM
  4. Injectors
    By FireRescueWS6 in forum General Help
    Replies: 1
    Last Post: 01-15-2008, 05:55 PM
  5. FS: 42 lb. Injectors
    By Packy in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 11-28-2006, 02:06 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •