Results 1 to 9 of 9

injectors

This is a discussion on injectors within the LT1 forums, part of the Vehicle Specific category; No power to the injectors gonna put a light on them any thing else that would help guys thanks...

  1. #1
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    injectors

    No power to the injectors gonna put a light on them any thing else that would help guys thanks

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    I take it you mean you're going to put a noid light on them to see if they are indeed firing? Stupid question, but have you checked the two fuel injector fuses? I don't remember exactly what size they are, 10A maybe?


    And I still think this could be a VATS issue. VATS does cut fuel and ignition.

  3. #3
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    Yes check all fuses I'm thinking it a vats problem too if I tune out the vats will that solve the problem

  4. #4
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    It definitely might fix the issue

  5. #5
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    Ok guy update found out the computer is no good so can i get a computer off any other car with the lt1 and it would work its need to b pro

  6. #6
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    It should work fine as long as it's the same year Camaro/firebird and trans. I don't think they need a crank relearn like the later model cars.

  7. #7
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    Well update guys I got a new computer and every thing works as it should so no more problem time for upgrades thanks guys

  8. #8
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    So you never replaced the opti since this all started, right?

  9. #9
    Junior Member Black beauty's Avatar
    Join Date
    Aug 2012
    Location
    memphis tn
    Posts
    62

    black
    1995 trans am

    No I have not

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. F.A.S.T. Injectors??
    By ThunderChicken in forum Internal Engine
    Replies: 7
    Last Post: 05-31-2011, 10:31 AM
  2. Injectors
    By duweller in forum External Engine
    Replies: 9
    Last Post: 06-22-2010, 07:27 PM
  3. 42 lb injectors yes or no
    By fast93ta in forum LT1
    Replies: 19
    Last Post: 02-04-2008, 11:27 AM
  4. Injectors
    By FireRescueWS6 in forum General Help
    Replies: 1
    Last Post: 01-15-2008, 05:55 PM
  5. FS: 42 lb. Injectors
    By Packy in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 11-28-2006, 02:06 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •