Results 1 to 2 of 2

has anyone used the delteq opti-direct ignition sy

This is a discussion on has anyone used the delteq opti-direct ignition sy within the LT1 forums, part of the Vehicle Specific category; has anyone tried this ignition? it looks easier to install then the optispark....

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Location
    Rosharon, Texas
    Posts
    4

    Teal & Black
    94 Z28

    has anyone used the delteq opti-direct ignition sy

    has anyone tried this ignition? it looks easier to install then the optispark.

  2. #2
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    I have read some threads about people wanting to use it and basically it uses the opti as a triger and keeps the high voltage out of it and prolongs the life. May be of great benifit for high rpm motors. something running 6500+ it may not fall on its face as easy as a single coil system.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Opti set up
    By 2000dreambird in forum LT1
    Replies: 9
    Last Post: 03-31-2010, 05:42 PM
  2. Anybody got any delteq stuff?
    By kensz28 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 09-08-2008, 07:21 PM
  3. opti direct coil change??
    By 94lt1ss in forum LT1
    Replies: 4
    Last Post: 11-09-2007, 06:01 AM
  4. Delteq, Accel 300 or MSD
    By grandkodiak in forum LT1
    Replies: 2
    Last Post: 06-19-2007, 07:47 PM
  5. WTB: Delteq system
    By RE AND CHERYL in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 07-30-2006, 03:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •