Page 1 of 2 12 LastLast
Results 1 to 20 of 40

Fuel Filter fixes everything...

This is a discussion on Fuel Filter fixes everything... within the LT1 forums, part of the Vehicle Specific category; Got a misfire? Replace the Fuel Filter! Have low horsepower? Replace the Fuel Filter! Won't start? Replace the Fuel Filter! ...

  1. #1
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152

    Fuel Filter fixes everything...

    Got a misfire? Replace the Fuel Filter!

    Have low horsepower? Replace the Fuel Filter!

    Won't start? Replace the Fuel Filter!

    Hesitation? Replace the Fuel Filter!

    Blinker problems? REPLACE THE FUEL FILTER!

    Girl Friend complains? Replace.... the.... Fuel.... Filter....

  2. #2
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    I just did an hour ago, seems like the fuel pump is my problem tho.


    300RWHP, 341RWTQ
    1/8 mile 8.32 at 83.97
    1/4 mile 13.049 at 105.24

  3. #3
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    fuel pump does not equal fuel filter. But congrats on replacing a part that didnt change anything.

  4. #4
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    No I mean my car has had trouble starting lately so I replaced the fuel filter. It didnt help much. im sure its the pump. now i have to upgrade to a walboro255

  5. #5
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    well good luck on finding your problem, but I'll tell you now that most the time when a fuel pump fails, its just stops working altogether. Not partially broken. And if you have low pressure, I think there is a pressure regulator that would come closer to fixing such a problem. Don't quote me on that. I'm not a fuel guy. Factory fuel pressure is fine for me. And as far as upgrading your fuel pump, well, unless its cheaper, I wouldn't waste your money. How long are you going to keep the car? see what I mean?

  6. #6
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    btw, people.. this thread was intended to be sarcastic.

  7. #7
    Member
    Join Date
    Feb 2008
    Location
    Russellville, MO
    Posts
    126
    I have had 2 different cars, my T-bird and my T/A both lose the fuel pump and they both started out with a momentary loss of power, then on both cars, neither one would start and then after they sat for a while they would start. Eventually the pumps quit altogther. I got my Walbro 255 cheaper than the stock replacement.

  8. #8
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    well a fuel pump is easy to tell if its broken. You wont hear it working. But I still stand firm on the theory that either it works, or it doesnt.

    I go with the 95% theory. not the 5% where it works sometimes if you let the thing set a while..

    Its broke if my car wont start when I want it to.

  9. #9
    Kenne-Bell Killer Cayenne97's Avatar
    Join Date
    Oct 2007
    Location
    Lake Tahoe, CA
    Posts
    609

    Cayenne Red, Pewter
    '97 Z28 1LE #53, '02 WS6

    Quote Originally Posted by 97bluebird View Post
    I have had 2 different cars, my T-bird and my T/A both lose the fuel pump and they both started out with a momentary loss of power, then on both cars, neither one would start and then after they sat for a while they would start. Eventually the pumps quit altogther. I got my Walbro 255 cheaper than the stock replacement.
    Those are the usual symptoms for fuel pump failure. They will start to die slowly. Start for a little while, run fine, sputter momentarily, and then eventually die. I've found in my extensive experience with LTx's that the fuel filter usually outlasts a lot of components on the car, including the fuel pump.

  10. #10
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    When Mine died the first time.. and wouldn't start, I said Its broken!! I aint waiting around next week or a few days or 5 hours, to see if it will start.

    The 2 times I had fuel pump failure it just died. Why wait around? How long does it take you to troubleshoot? I'm not waiting around 3 days to see if it will start.
    Last edited by Chad97SS; 11-06-2008 at 07:56 PM.

  11. #11
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Well I just replaced the starter, fuel filter, and fuel pressure regulator and car still has trouble starting. I would have to turn the key to the on postion then back off, then i hear this kinda whistling noise, (repeat process 1-3 times) then it would crank right up. All thats left is the fuel pump, so might as well get a 255 and if it doesnt fix it then idk whats wrong with car.

  12. #12
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Unless anyone else can think of whats wrong with it?

  13. #13
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Quote Originally Posted by JwMonE99 View Post
    Well I just replaced the starter, fuel filter, and fuel pressure regulator and car still has trouble starting. I would have to turn the key to the on postion then back off, then i hear this kinda whistling noise, (repeat process 1-3 times) then it would crank right up. All thats left is the fuel pump, so might as well get a 255 and if it doesnt fix it then idk whats wrong with car.
    That noise you hear is probably the air pump. What kind of trouble does it have starting?

  14. #14
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    Its easy to tell the different between air pump and fuel pump because both sounds come from opposite ends of the car. =) Plus the air pump is much louder. Unless your fuel pump is really bad and making a ton of noise. Like on a 3rd gen f-body.

  15. #15
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    I hear a noise from both sides of the car. when I turn it to the on position I hear somthing from the rear. Kinda hard to explain it. Then when I turn it off I hear the whisting noise from the front of the car.
    After cycling the fuel 1-3 times it would crank right up if not it just makes a noise like its trying to crank but I guess it doesnt hold pressure.

  16. #16
    New TL /sold my 9th Fbody Chad97SS's Avatar
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    152
    The fuel pump normally runs for about 3or 4 seconds when the key is initially turned on to pressurize the the line. Then the relay stops it from pressurizing because you can hear it click and then the pump shuts up. But if the line is already pressurized you may not hear it run for 3 or 4 seconds and then stop. See, overnight the line looses its pressure. And in the morning is the best time to change the filter because there is only just a little bit of pressure on the line and you dont loose nearly as much gas when changing it. But if the car has been started "recently" like in the past 30 minutes or hour or so, the line may still be already pressurized so the pump doesn't "act" quite the same as when there is no pressure.

    Have you had an SES light when the engine is running?

  17. #17
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Yea I have an SES light but I have no cats either.
    I will try to get a code 2morrow. My car has been like this since I bought it last year, im jsut now getting around to fixing it lol.

  18. #18
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Checked codes today, got 2 o2 sensores but i have no cats. And an EGR valve problem. Any relationship? I have pace setter LTs, and I dont have the EGR block off plate yet.

  19. #19
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    TTT

  20. #20
    12.36@109 Red on Red WS6's Avatar
    Join Date
    Nov 2005
    Location
    Tulsa OK
    Age
    38
    Posts
    454

    Red
    1996 Trans Am

    A fuel pump is one of the easiest to diagnose. Go to your local auto store and borrow or buy a fuel injection pressure tester. Screw it on the schrader valve on the fuel rail and turn the ignition on. You should have a pressure around mid 40's or higher. If nothing or If you don't want to get a gauge there is a red wire with a black end by it's self hanging out in the wiring harness on the passenger side wheel well close to the cars computer. Apply 12 volt jumper wire to it and listen for the fuel pump. If the pump works and gives the proper amount of pressure with the jumper wire then you have a blown fuse, bad relay or wiring issue. Do this and report back letting us know how it went.
    96 WS6 Trans Am LT4 Hot Cam, Pacesetter LT, 2.5" Xpipe into Dynomax, 3000 Stall Edge racing converter, Trans go shift kit,Tuning by me, MSD6A, CSR waterpump 328 RWHP 12.36 @ 109

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. kinked fuel line while changing fuel filter
    By krese in forum Firebird / WS6
    Replies: 4
    Last Post: 10-04-2010, 04:02 PM
  2. Question: Does a new fuel pump mean a new fuel filter too?
    By RaceMyLS1 in forum General Help
    Replies: 3
    Last Post: 02-17-2009, 12:11 AM
  3. fuel filter or fuel pump?
    By formulaon18s in forum General Help
    Replies: 6
    Last Post: 11-20-2007, 05:14 PM
  4. Fuel Filter?
    By White/Red/Z28 in forum General Help
    Replies: 4
    Last Post: 10-24-2007, 06:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •