Results 1 to 8 of 8

forgot this one

This is a discussion on forgot this one within the LT1 forums, part of the Vehicle Specific category; after 500 miles my check engine soon light went on.. it freaked me out cus last time it turned on ...

  1. #1
    Junior Member TAallday's Avatar
    Join Date
    Oct 2008
    Location
    san jose, CA
    Posts
    56

    blackk
    1996 camaro z28

    forgot this one

    after 500 miles my check engine soon light went on.. it freaked me out cus last time it turned on it was the mass airflow sensor.. so it stay on and like 50 miles later it turns off. then again it turns on and 50 or more miles it goes off...and tonight it was on again then off at 20 miles? i know if you scan it it tells you whats wrong but what can it be if it goes on and off like that? something small?

  2. #2
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by TAallday View Post
    after 500 miles my check engine soon light went on.. it freaked me out cus last time it turned on it was the mass airflow sensor.. so it stay on and like 50 miles later it turns off. then again it turns on and 50 or more miles it goes off...and tonight it was on again then off at 20 miles? i know if you scan it it tells you whats wrong but what can it be if it goes on and off like that? something small?
    Do you have a cat on it? Maybe a sign cat is becoming pluged. Causeing it to intermitently throw an 02 sensor code.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  3. #3
    Junior Member TAallday's Avatar
    Join Date
    Oct 2008
    Location
    san jose, CA
    Posts
    56

    blackk
    1996 camaro z28

    no my car is stock. did change the mass airflow sensor. should i take it back to the shop and ask her if the MAF is working prop? i did replace the clutch.. but the light wont be on for that right?

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by TAallday View Post
    no my car is stock. did change the mass airflow sensor. should i take it back to the shop and ask her if the MAF is working prop? i did replace the clutch.. but the light wont be on for that right?
    Umm if your car is stock it most likely has a cat on it....What's the mileage?

  5. #5
    Junior Member TAallday's Avatar
    Join Date
    Oct 2008
    Location
    san jose, CA
    Posts
    56

    blackk
    1996 camaro z28

    i though after market cat for some reason.. 87,2xx miles

  6. #6
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    why?

  7. #7
    Dealing Powder ntimid8r7's Avatar
    Join Date
    Sep 2008
    Location
    Saint Cloud,FL
    Age
    39
    Posts
    194

    1994 Z28 MQBM
    2001 SS #1629 LPM

    check your gas cap

  8. #8
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Could be a lot of things. I had a problem with my air pump, it would turn on the light randomly. Have it scanned and see what comes up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Almost forgot... I tried it....
    By silverWS6 in forum Almost Anything Goes
    Replies: 143
    Last Post: 01-03-2010, 10:50 AM
  2. I forgot how much fun it is...
    By ls1camino in forum Almost Anything Goes
    Replies: 6
    Last Post: 10-05-2009, 05:14 AM
  3. I Forgot To Tell Yall
    By everett in forum Almost Anything Goes
    Replies: 10
    Last Post: 12-15-2006, 10:19 AM
  4. Forgot about another Q with the cutout
    By pipes_ta in forum Firebird / WS6
    Replies: 2
    Last Post: 10-18-2006, 11:45 PM
  5. i forgot my introduction
    By wsilver6 in forum New Member Introductions
    Replies: 2
    Last Post: 07-22-2006, 05:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •