Results 1 to 6 of 6

F-in 1LE elbow and air foil! Please help!

This is a discussion on F-in 1LE elbow and air foil! Please help! within the LT1 forums, part of the Vehicle Specific category; Ok, so I tried installing the 1LE elbow onto my car yesterday. I could not get the elbow to slide ...

  1. #1
    Member
    Join Date
    Aug 2005
    Location
    Ohio
    Age
    32
    Posts
    583

    Black
    97 Formula

    F-in 1LE elbow and air foil! Please help!

    Ok, so I tried installing the 1LE elbow onto my car yesterday. I could not get the elbow to slide onto the TB for the life of me. I got it onto the MAF no problem, but it doesn't want to slide all the way on to the TB. I can get the left side of it on, but it doesn't want to completely stretch over to the right side. I also have the Moroso CAI if that makes any difference?

    I hooked up the air sensor and opti-vent so that I could get the car back in the garage. I'm going to have my dad try and help me install the damn thing later today. Any tips to make it work?

    [I just noticed how large that donkeydong thing really is when I took it out]

    P.S. I installed my CompCams airfoil while I was at it. When I started the car, it just died on me. I tried again with the same results. I removed it for now. I think I read somewhere that I should make the air hole on the bottom if it bigger to keep the car from stalling?

    Also, since I wasn't able to reconnect the elbow to the TB, I just left it where it was with the sensor and opti-vent tube attached just to get it in the garage. But I now have an SES light. Is that due to the elbow being disconnected? And will it go away once it's reconnected?

  2. #2
    I installed my airfoil with no problems at all, but I certainly cant see it causing your motor to stall out... unless you dropped a screw down there LOL. See if you knocked the MAF wires loose, they are SUPER sensitive, and could very well cause your motor to choke on ya.

    Although I dont have a 1LE elbow yet, I had a very simliar problem when I installed my CAI, the filter would NOT fit.. i tried for almost an hour before giving up for a few. i came back to it with a friend and we managed to get it on, you really have to stretch out new parts to get them on... try alittle lube see if that helps slip it on.

  3. #3
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    You might try using a heat gun and warming up the rubber elbow to help it stretch, and maybe using something as a lubricant like WD40.

  4. #4
    Member
    Join Date
    Aug 2005
    Location
    Ohio
    Age
    32
    Posts
    583

    Black
    97 Formula

    Update: So I got the elbow on with the help of a friend, what a pain in the ass. I completey removed the MAF to install the elbow, and then reconnected everything. But, the SES light is still on. I'm thinking the sensor that came with the elbow could be bad?

    Could I just remove the sensor from the old elbow and install it onto the new one?

  5. #5
    Junior Member
    Join Date
    Jul 2005
    Location
    Santee, CA
    Age
    56
    Posts
    95
    Provided that everything is correctly hooked back up, the light should eventually go out.

    I believe the computer needs 3 sucessive "non-event" readings (no-repeats of the particular error code) in order to turn the SES light off. In other words, you will probably have to start up and drive your car around 3 times for the light to off.

    Either way, you can still drive your car around safely.
    Vance Chula
    1996 Camaro Z28 SS #1688
    2010 Camaro 2LT RS
    http://www.cardomain.com/id/vchula

  6. #6
    Member
    Join Date
    Aug 2005
    Location
    Ohio
    Age
    32
    Posts
    583

    Black
    97 Formula

    Ok, the SES light went away after driving it around for a little bit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 9/11 Tin Foil Hat wearers...this is for you....
    By SMWS6TA in forum Political / Debate Forum
    Replies: 5
    Last Post: 12-21-2015, 04:11 PM
  2. 1LE elbow and air foil for LT1
    By Firebirdjones in forum Parts For Sale / Trade
    Replies: 9
    Last Post: 04-02-2009, 05:27 PM
  3. Tin foil car....
    By bad boy 99 in forum Almost Anything Goes
    Replies: 7
    Last Post: 12-17-2007, 08:16 AM
  4. Air foil?
    By camarostripes96 in forum LT1
    Replies: 23
    Last Post: 08-07-2006, 09:56 PM
  5. Air Foil?
    By 95TA383 in forum External Engine
    Replies: 4
    Last Post: 02-14-2006, 03:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •