Results 1 to 4 of 4

engine dying

This is a discussion on engine dying within the LT1 forums, part of the Vehicle Specific category; I've got an Lt1 and when i accelerate from a stop or at least a very low idle (slow traffic) ...

  1. #1
    hate ricers midnight-Z28's Avatar
    Join Date
    Aug 2005
    Grand River, IA

    1998 Z28 - A4

    Exclamation engine dying

    I've got an Lt1 and when i accelerate from a stop or at least a very low idle (slow traffic) the car will choke and sputter when i go to accelerate then it will catch and take off rather jerky. it does it probably 75% of the time and it will do it when the engine is cold and when it is warm, and it will sometimes die... anyone with any suggestions, i have changed spark plugs, ran professional injector cleaner through the fuel rail. ideas or suggestions more than welcome.

  2. #2
    Check your fuel pressure.

  3. #3
    Junior Member
    Join Date
    Oct 2005
    Riverside, CA

    1996 camaro Z28

    i have the same problem ... but mine dies when im on reverse... i have no idea why its does that... its it hte fuel pump??

  4. #4
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Lost in Texas

    Custom Slate Blue
    99 B4C

    could be as simple as a fuel filter ot a pcv. Also check the hose going to the pcv, it's good at getting melted on LT1 s and it'll run like that

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Some insight into the 3.4L OHV Motor...
    By Black34v6 in forum V6
    Replies: 116
    Last Post: 10-08-2016, 04:03 AM
  2. Replies: 15
    Last Post: 01-25-2006, 10:21 PM
  3. 99 Corvette bone stock Complete LS1 Engine 17,000 miles
    By chrisjw1 in forum Parts For Sale / Trade
    Replies: 14
    Last Post: 01-20-2006, 07:39 AM
  4. Engine is dying SES is blinking... HELP!!!
    By sk8runeg in forum Internal Engine
    Replies: 40
    Last Post: 12-24-2005, 02:59 PM
  5. 160 thermo
    By jcot72 in forum General Help
    Replies: 31
    Last Post: 11-25-2005, 02:32 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts