Results 1 to 3 of 3

Comments/suggestions on an ongoing power window issue

This is a discussion on Comments/suggestions on an ongoing power window issue within the LT1 forums, part of the Vehicle Specific category; Original owner - '93 Formula. Driver's side window motor died around 2004. I replaced it with an A1 motor and ...

  1. #1
    Junior Member
    Join Date
    Aug 2007
    Location
    Richmond, Texas
    Posts
    3

    Comments/suggestions on an ongoing power window issue

    Original owner - '93 Formula. Driver's side window motor died around 2004. I replaced it with an A1 motor and 2 years later the passenger side croaked. I waited to replace that one and the driver's side also failed about 6 months later. 2007 I replaced both and the driver's side lasted about 9 months. Again, I waited a year or so before replacing.

    Late 2011, I replaced both window motors and replaced the rollers on the bottom of the driver's window as one was bent. I thought it might be making the motor work harder. I also installed dual relays on both doors to provide power directly from the battery to the motor. The rocker switches only had to trigger the relays. This mod got me to early 2013 where the motors started to run very slow. After a few stalls with the window down, I was able to get both back up. Didn't drive the car much in 2013, so just left it parked in the garage.

    In April of this year, I replaced both motors and regulators and had a professional shop do it, just in case my skills were part of the problem. It's now August and my driver's side stalled this week. I was able to get it back up within a few minutes.

    I have replaced the driver's side 5-6 times now in the past 10 years and the passenger side twice.

    Any comments or suggestions on what the next step should be? Try a different brand motor i.e. Seimens, Dorman, AC Delco? Convert to manual????

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Look for the AutoTrix's window fix. I can't post a direct link because they are not a sponsor.

    What's happening is a constant problem that plagues our 4th gens. Simply put - GM engineers thought it was a great idea to run a single power wire to the drivers window switch and then continue it to the passenger side switch. By the time the voltage gets to the passenger side it is significantly lower. Over time this under current kills the passenger motor and will also effect the drivers side as well.

  3. #3
    Junior Member
    Join Date
    Aug 2007
    Location
    Richmond, Texas
    Posts
    3
    Quote Originally Posted by SMWS6TA View Post
    Look for the AutoTrix's window fix. I can't post a direct link because they are not a sponsor.

    What's happening is a constant problem that plagues our 4th gens. Simply put - GM engineers thought it was a great idea to run a single power wire to the drivers window switch and then continue it to the passenger side switch. By the time the voltage gets to the passenger side it is significantly lower. Over time this under current kills the passenger motor and will also effect the drivers side as well.
    SMWS6TA,

    I have relay's providing power to both motors up and down directly from the battery. The factory rocker switches only provide power to the relay - maybe 1-1.5 amps max. Whatever it takes to trigger the relay. Seems to be the same think the AutoTrix kit does.

    The relays are located under the dash closest to the window. Wiring goes direct from the relay to the motor. I spliced into the wire harness using the electrical connector for the motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: window issue
    By 2000dreambird in forum Stereo and Electronics
    Replies: 7
    Last Post: 09-11-2013, 07:04 AM
  2. window issue
    By phoenix05 in forum General Help
    Replies: 6
    Last Post: 07-17-2009, 04:59 PM
  3. Power Window and Lock issue
    By GoldenFlame in forum Camaro / SS
    Replies: 5
    Last Post: 05-07-2009, 04:24 PM
  4. Planned mod path: suggestions, comments, flames?
    By Aetos in forum General Help
    Replies: 7
    Last Post: 10-20-2008, 12:51 PM
  5. Camaro Window Switch/1le window/power lock delete kit
    By Marc1130 in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 03-13-2007, 12:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •