Results 1 to 3 of 3

car runs like shit

This is a discussion on car runs like shit within the LT1 forums, part of the Vehicle Specific category; whats up i got a problem with my 94 camaro i just got it back off this guy cause i ...

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Location
    meida,pa
    Age
    30
    Posts
    31

    red
    1994 chevrolet camaro z28

    car runs like shit

    whats up i got a problem with my 94 camaro i just got it back off this guy cause i was gonna trade him but i decided not to and when i gave it to him it ran fine and now when i drive it and give it gas it has no balls at all. it takes a while and then sometimes it will take off but right now it has no power. any ideas

  2. #2
    Fuzzbuster Jr. fluke's Avatar
    Join Date
    May 2007
    Location
    Cave Run Lake area, Kentucky
    Age
    33
    Posts
    1,002

    Pewter
    2002 T/A WS6

    Could be many things. He may have worn the clutch down and it's slipping. Or he may have put some crappy fuel in it. If it's leaking fluids he may have screwed it up beating on it (check those). Who knows what he may have done to it, just give it a good check over.

    My 2002 Pontiac Trans Am WS6... ASC# 1244 ... Born on June 23, 2001

  3. #3
    Junior Member
    Join Date
    Feb 2008
    Location
    meida,pa
    Age
    30
    Posts
    31

    red
    1994 chevrolet camaro z28

    Quote Originally Posted by fluke View Post
    Could be many things. He may have worn the clutch down and it's slipping. Or he may have put some crappy fuel in it. If it's leaking fluids he may have screwed it up beating on it (check those). Who knows what he may have done to it, just give it a good check over.


    yea i dont kno what he did lol it sucks he only had the key for a day then i got it back it just sucks cause it has no balls at all anymore a dam 4 banger can beat me now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Runs much better!
    By TLS_Addict in forum LT1
    Replies: 7
    Last Post: 04-19-2010, 11:13 AM
  2. It runs
    By SHines-IT in forum Multimedia Section
    Replies: 3
    Last Post: 10-25-2009, 11:24 AM
  3. Z06 with only DR runs 10.85
    By powermad in forum Corvette
    Replies: 20
    Last Post: 11-16-2006, 07:21 PM
  4. It runs once more
    By bigman1 in forum Southern Members
    Replies: 5
    Last Post: 09-24-2006, 12:50 PM
  5. Engine runs rough, idles rough, runs rich
    By skintox in forum General Help
    Replies: 2
    Last Post: 08-22-2006, 04:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •