Results 1 to 4 of 4

A/c Problems (94 Camaro)

This is a discussion on A/c Problems (94 Camaro) within the LT1 forums, part of the Vehicle Specific category; Im looking for some suggestions on why my a/c doesn't blow out of the front vents on my 94 camaro?? ...

  1. #1
    Junior Member
    Join Date
    Mar 2011
    Location
    Middleburg FL
    Posts
    2

    Black
    94 Z28

    A/c Problems (94 Camaro)

    Im looking for some suggestions on why my a/c doesn't blow out of the front vents on my 94 camaro?? I seems to work on all of the a/c settings hi/low etc... but only blows out of the floor vents and the defrost vent... I can't seem to visibly see any cacked or broken vaccume lines. Is there a common issue with this type of thing or any suggestions of what to look for or where to start? Any help and input would be greatly appreciated.

    Thanks in advance

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Seems like the blend doors are stuck, or the system that controls them (I believe it is vacuum controlled) isnt working.

  3. #3
    Junior Member
    Join Date
    Mar 2011
    Location
    Middleburg FL
    Posts
    2

    Black
    94 Z28

    I thought the same thing, but have pulled the dash apart and traced all of the lines... There arent any visible problems that I can see. The blendoor works great too. Im at as loss really, I cant understand why it wont blow out of the vents...

  4. #4
    Junior Member jloshotz's Avatar
    Join Date
    Apr 2011
    Location
    N.Y.
    Posts
    13

    Medium Quasar Blue
    1995 Camaro Z28

    Under the hood near where the a/c lines go into the evap at the firewall is a small plastic check valve, which I can practically guarantee is broken....about a five dollar fix. Give it a look see

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Old school camaro with wheel hop problems.
    By Street Fighter in forum General Help
    Replies: 2
    Last Post: 01-22-2014, 12:52 PM
  2. Question: 2002 Camaro Emission Problems
    By Austin_Heat in forum Camaro / SS
    Replies: 0
    Last Post: 10-01-2009, 06:54 PM
  3. 2010 camaro in my shop with problems already
    By blue02Z in forum Almost Anything Goes
    Replies: 45
    Last Post: 04-29-2009, 09:47 PM
  4. Camaro shift problems
    By miller456 in forum New Member Introductions
    Replies: 4
    Last Post: 02-21-2007, 08:29 PM
  5. 1999 Camaro SS problems?
    By bdd in forum General Help
    Replies: 8
    Last Post: 03-13-2006, 04:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •