Results 1 to 6 of 6

AC problems need some help!!!!

This is a discussion on AC problems need some help!!!! within the LT1 forums, part of the Vehicle Specific category; I have a 96 Black trans am LT1 and my ac is acting up. i can get off of work ...

  1. #1
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    Angry AC problems need some help!!!!

    I have a 96 Black trans am LT1 and my ac is acting up. i can get off of work and my ac will come on but my compressor will not come on sometimes, and i can cut my car off and cut it back on and my compressor will come on, but it takes like 5 to 10 mins to even get cold , and whenever it does get cold , it stays cold for about 1 min and then gets kinda warm and then back to cold and back and forth...i am not an ac person so i hope someone can let me know whats going on.. How much pressure am i supposed to have and what do i need to do?? Its hot down here and i am getting frustrated. sometimes the compressor cuts on and sometimes it doesnt and i dont know if there is to much freon or not enough, so PLEASE HELP!!!!!!!!!!!!!!!

  2. #2
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    I know on many AC setups the system will shut itself down if there isnt sufficient charge inside. Yours probably needs to be flushed and recharged.

  3. #3
    Member Chad97z's Avatar
    Join Date
    Aug 2005
    Location
    Dallas / Irving
    Posts
    396
    just go to walmart and get a can if 134a and put in as much to get you in the green area of the gauge. Thats probably about 25 pounds or so. It doesnt have to be jam packed full. It wont make it any colder. Just enough to make it work and a little more. =) Or if there is too much, it could cause it to shut off too. Who knows. Put a gauge on it. Some of the cans at wally world have guages on them

  4. #4
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    i have put one of those shitty gauges on , and didnt really tell me the pounds on it just has the color codes, so i dont know what the deal is , i may have to put the big gauges on it, and see , any ideas

  5. #5
    Member Chad97z's Avatar
    Join Date
    Aug 2005
    Location
    Dallas / Irving
    Posts
    396
    ok well green is good. Thats all I know. A/c systems are like air bag systems. not much info.

  6. #6
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    well it says the blue is good and green is low......does anyone know what the low side is supposed to read and the high side supposed to read , whenever its full , i have a 96 trans am LT1 ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •