Results 1 to 4 of 4

94 Z28 A4 wont go into OD

This is a discussion on 94 Z28 A4 wont go into OD within the LT1 forums, part of the Vehicle Specific category; Has anyone had this happen? Any ideas? Took the car to the local shop, they said about $2500 for a ...

  1. #1
    Member PatrizioD's Avatar
    Join Date
    Nov 2007
    Location
    The Anus of America; RI
    Posts
    381

    Nero
    2006 gto

    94 Z28 A4 wont go into OD

    Has anyone had this happen? Any ideas? Took the car to the local shop, they said about $2500 for a rebuilt trans, installed. Seems to be it shouldnt need to be completely replaced, especially if its just a controller problem or what not. The car drives fantastic otherwise.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    wow, Did they tell you why it had to be rebuilt? Any codes? When was the last time you flushed the fluid and changed the filter? I personaly had the same issue With my Z28, After a little research i figured out it was just the OD solenoid on the inside of the transmission. Iv seen the solenoid's just get clogged with Debris, Ie metal shavings, to much transmission stop leak etc etc. All you have to do is drop the trans pan the solenoid is located on the valve body.
    Not saying that is your issue but the sensor is about 30 bucks compared to 2k, and if they do a "complete" rebuild they will replace it anyhow.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    do you have lockup in third?

  4. #4
    Member PatrizioD's Avatar
    Join Date
    Nov 2007
    Location
    The Anus of America; RI
    Posts
    381

    Nero
    2006 gto

    What exactly does that mean Jay? Im not too good with A4's, since my DD is an M6 GTO...this A4 Z28 is really just a project car

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: car wont start and now gauges wont work!
    By AB'sLs1 in forum General Help
    Replies: 52
    Last Post: 04-20-2013, 09:54 PM
  2. Help: car wont go?
    By FMR_TransAm in forum General Help
    Replies: 13
    Last Post: 04-17-2012, 08:21 PM
  3. T56 wont go into 3rd or 4th
    By mw98transam in forum Manual Transmission
    Replies: 5
    Last Post: 06-02-2010, 04:09 PM
  4. My car wont go into o/d
    By Speedy_Gonzales in forum Automatic Transmission
    Replies: 21
    Last Post: 02-07-2008, 03:50 PM
  5. SLP Air-Box lid wont fit?
    By GlowStickgl in forum General Help
    Replies: 8
    Last Post: 01-11-2006, 11:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •